Skip to Content
avatar image
Former Member

IDM 7.1 SP3.1 - Manage Tab - Search for entries

Hi there

After update to 7.1 SP03 Patch 1 I cannot search for users in the Manage-Tab of the WebUI. For example I have a user with MSKEYVALUE "testuser". If I search for "testuser" the UI says "Entries could not be searched" (or similar; original message in german: "Einträge konnten nicht gesucht werden"). If I search for "testuser" (plase note the wildcards/asterisks) it works.

Is this a bug or a feature?

Is there something wrong with my DB-index?

Did something go wrong during the update ?

I use Win2003 32bit MSSQL '05 with latest IS-schema update & fulltext search enabled, UI v03_1, Designtime v03_1 & Runtime v03_1 as available from SMP

Any help or hints appreciated.

Regards

Michael

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Nov 27, 2009 at 02:01 PM

    In AS-Java LogViewer I can see following entry when this error occurs:

    "The SELECT permission for Disabled-column, MXI_VALUES, mxmc_db, dbo-Schema was denied" (in german: "Die SELECT-Berechtigung wurde für die Disabled-Spalte des MXI_VALUES-Objekts, mxmc_db-Datenbank, dbo-Schema verweigert.")

    SQL statement is "SELECT distinct top 200 mskey from mxi_values VALS where contains (SearchValue,?) AND Attr_id IN (?,?,?,?) AND disabled=0 AND EXISTS (SELECT MSKEY FROM MXIV_VALUES WHERE SEARCHVALUE=? AND ATTR_ID=? AND mskey=VALS.mskey)".

    I use MSSQL05, mxmc_db_rt-User for connection between AS Java & MSSQL, mssql-jdbc-driver v1.2.

    I'm quite confused that it works in case I use wildcards.

    Anyone has an idea?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Solved:

      1. In MS-SQL Management Studio (I don't know exact english descriptions, but I'll try to translate), goto _prov_role & open properties dialog.

      2. Goto Securable Elements ("Sicherungsfähige Elemente"), in the upper window search for table MXI_VALUES, highlight it.

      3. In the lower part highlight the line with the Select permission. Do not click the grayed-out checkbox "Grant" cause else you will loose all inherited permissions.

      4. When Select is highlighted click button "Column Permissions" and Grant column "Disabled"

      Now it works. I never thought one could grant permissions on column level... but I'm no database guy 😊

      I noticed in the SAP database-script "4-Update-Schema.sql" the column Disabled was added to MXI_VALUES during some update (don't know which). Maybe they forgot (?) to add the permissions for new column to any other sql-update-script? Maybe there's something wrong with my database (I first installed 7.1.0, then SP01 to SP03 Patch1 as soon as they were released)?

      Regards

      Michael