Skip to Content
avatar image
Former Member

SAP_PAYSLIP_DE_P

Hello,

I'm working with the Adobe Form SAP_PAYSLIP_DE_P and I'm getting the wage types displayed, but the descriptions of the wage type are not displayed. The fields for description exists on the form and I can edit them in Formular Editor.

Do you have any idea why this happens?

Thank you!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Nov 19, 2009 at 03:03 PM

    You´re welcome, I am always ready to help. Note: To resolve this we will need more details. In your next post the more details you provide the faster we can move on:))

    I would check this:

    1) When you open the form layout of this form in transaction SFP, do you see what you expect? Or you miss something here?

    2) If 1) is ok - use F8 in SFP to create a blank form. Do you miss something here?

    3) Generate the form the way you do it all the time. But before you start the program, use "/h" in the sap menu to start debugging. You need to get close to the point where the data are passed from ABAP to Adobe form. At this point all the data must be prepared. If something is missing here, it means there is a problem in data loading, not in Adobe form.

    To get here, use breakpoint on FMs: FP_JOB_OPEN and FP_JOB_CLOSE (the form is generated between these two FMs). So you can check all the data that will be passed to the form.

    4) check the customizing tables for the texts you´re missing if you miss data and not the form layout

    Note: Maybe not this time but soon you will use the Adobe trace. Start it in SFP menu. Set very detailed trace. When you get you form generated it will include many useful files attached to the PDF file. Use attachment icon in Reader to access the files.

    Hope this helps you to start, Otto

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 19, 2009 at 02:48 PM

    In case you talk about the form layout, it is possible the form does not have the right language version. In case you talk about data you should debug the data loading procedure and care for the language as well. Imho there is not a real error, just some misunderstanding. Regards, Otto

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 19, 2009 at 02:50 PM

    Hello Otto,

    thank you for your quick answer.

    Since I'm new in this area, can you tell me how and where can I start the debugging?

    Regards,

    Bogdan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 23, 2009 at 01:25 PM

    Hello Otto,

    thanks again for the help. I have found the problem with the Debugger.

    Regards!

    Add comment
    10|10000 characters needed characters exceeded