Skip to Content
avatar image
Former Member

Design Studio - No displayed Measures in InfoChart

Hello,

by any reason, it often happens that during development in Design Studio, some info chart components lose their "connection" to the measures of a data source.

The result is, at additional properties, in tab "Data Series" I can still see the color palette, but under "Displayed Measures" I can see the message "There is no data".

My questions now are:

1. Is there a way to solve this Problem? (Resetting Initial views doesnt solve the Problem)

2. If number 1 cannot be solved, is there a way to change a measure from line type to column type by CSS?

Thanks in advance!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Nov 22, 2016 at 05:29 PM

    What do you mean, lose their connection? I am not sure I follow. Are you on the latest 1.6 SP?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 22, 2016 at 04:02 PM

    Additional screenshots for the question:

    displayed-measures-problem.png

    measures-existing.png

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 23, 2016 at 07:20 AM

    Yes, we are on latest 1.6 Service pack.

    It does not phisically lose the connection. I wanted to describe that there are no longer measures existing in the additional properties window at "Data Series" --> Displayed Measures.

    And this, although they are existing in the query (Initial view of Design Studio & Chart configuration dialogue).

    It Looks like the info Chart component is broken regarding this aspect. But If i rebuild the graphic completely, I do have the same result.

    In the screenshot above you can see what it Looks like.

    Thanks a lot!

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 23, 2016 at 12:26 PM

    That is interesting; I am on SP3 patch 1 and I don't see that in my data series. I recommend submitting an incident to SAP Support. You have an interesting find.

    Out of curiosity, which type of chart were you selecting? Bar chart or?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 23, 2016 at 03:41 PM

    It is a Info Chart --> Combined Column Line Chart..

    Thanks for your help.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 23, 2016 at 06:02 PM

    Hi Johann,

    Is your chart working fine initially and it gets affected after a specific change in property or it is not working from starting?

    Because by default the combination chart takes first measure as column and second measure as line.

    Thanks,

    Poovarasan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Johann,

      I think the chart works fine but the data has the problem.

      Is there any invalid data in your query such as empty data that doesn't even have zero?

      And can you try plotting the two measures in two different charts?

      If you get any error in plotting in charts separately then you can look for the error in that measure.

      Thanks,

      Poovarasan

  • Nov 24, 2016 at 03:17 AM

    Johann - I see it on 1.6 SP3 patch 1 - released earlier this month - could you try applying the patch? See below:

    Add comment
    10|10000 characters needed characters exceeded