Skip to Content
avatar image
Former Member

Redolog file is not showing active

Hi

We just upgraded BRTOOLS to 640 (51) in our production system; since then redolog file is not showing "ACTIVE".

See the resutls

SQL> select group#, status from v$log;

GROUP# STATUS

-


-


11 INACTIVE

12 INACTIVE

13 CURRENT

14 INACTIVE

SQL>

In the morning aslo it was as above status; we did altered the switch log and one group was showing correctly as ACTIVE and its next group was showing CURRENT but now again it changed to above status.

Can you please let me know why it is not showing status "ACTIVE"

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 17, 2009 at 05:33 PM

    Hello Kasinath,

    the official documentation is your friend:

    http://download.oracle.com/docs/cd/B19306_01/server.102/b14237/dynviews_1150.htm#I1030127

    ACTIVE - Log is active but is not the current log. It is needed for crash recovery. It may be in use for block recovery. It may or may not be archived.

    So of course, if you perform a logswitch the data is not completely checkpointed and so it is still needed for crash recovery. After a while all the corresponding data is written down to the data files and so the status changes to INACTIVE.

    Regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Kasinath,

      > Why it is not like that in this case?

      Because of in your other databases the corresponding buffers are not flushed to the data files until yet (checkpoint not completed).

      You can verify this by comparing the SCNs of the data file headers and the SCNs that are covered in the redo log groups.

      Regards

      Stefan

  • avatar image
    Former Member
    Nov 17, 2009 at 08:54 PM

    Very good answers with quick response....Great keep it up.

    Add comment
    10|10000 characters needed characters exceeded