Skip to Content

Hide filed unchecked in Rsa6 still appears in Rsa5

Hello

I am enhancing datasource 0costcenter_attr.

I added a new field to the append structure. activated the structure and then saved the datsource. went into Rsa6 and unchecked the hide field for the new field which i included. did a check in rsa3 and the field is shown up there with data.

but when i go to rsa5 the field still shows as hidden. When i replicate the datsource in BI the new field is not coming in.

Please can somone suggest any ideas if encountered this?

I know there is a table where we can maintain the entries by doing /h.

thanks

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Posted on Nov 18, 2009 at 03:47 AM

    Hi,

    If it is stiil there then use the following program and chage the prperties of the fields in ROOSFIELD table. here I given the program as per my requirement, so you need to chnage the field and datasource names.

    REPORT ZBI_ROOSFIELD NO STANDARD PAGE HEADING .
    
    tables ROOSFIELD.
    Update ROOSFIELD set SELECTION = 'A' where
    OLTPSOURCE = '0MAT_PLANT_ATTR' and
    FIELD = 'EISBE'.

    Thanks

    Reddy

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 17, 2009 at 04:12 PM

    check if the table ROOSFIELD has any setting against the field ...

    This table has the fields in the extractor - do not have any datasources with hidden fields and hence cannot check at this moment...

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 17, 2009 at 06:22 PM

    Hi Tom,

    Cud u activate and Try once again.

    Uncheck all the fields in RSA6 and Activate the Structure / Datasource once again.

    Replicate the DS in BW.

    Rgds

    SVU123

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 17, 2009 at 08:03 PM

    Hi

    this is a problem is the selection of the fields( here the unhide in the selected , but we need to make all the field visible)

    You would need to change the values for the SELECTION field in the ROOSFIELD table and make the fields visible.

    If a field is hideen then the SELECTION value in the table would be A. You would need to make it "P" or M based on the requirement

    Check if you have authorization to change the values otherwise you would need to write an ABAP program

    for this you need to follow the steps

    Step 1

    Go to the Se11 in ECC, Give the table name ROOSFIELD

    Step 2

    under OLTPSOURCE give the data source name 0costcenter_attr press F8

    Step3

    Select the field the you want to make visible and double click on the field, now you can see Table ROOSFIELD display

    on the selection field tab press F4 you will have

    A Field in OLTP and BW Hidden by SAP

    M Selection Required, Visible

    No Selection Possible, Visibility Set

    P Selection Adjustable, Visibility Set

    X Selection Adjustable, Visibility Set

    1 Pure Selection Field, Selection Set

    2 Pure Selection Field, Selection Set

    3 Selection Adjustable, Visibility Adjustable

    4 No Selection Possible, Visibility Adjustable

    Now you need to select the second option that is "M" , but you can change it because its not in the change mode

    Step 4

    on the same screen Table ROOSFIELD display

    type /h on the place when we type transaction code . press enter for 2 times you will get in to the debugging mode screen.

    Step5

    click on if code = 'SHOW'

    below the the field will be displayed as Show

    now click on the pencli button side (that is change mode type EDIT erasing show)

    now save it press F8

    Step 6

    Now you will get back to the screen Table ROOSFIELD display , now you have the privelage of selection the the selection . Change the selection to M Selection Required, Visible. save it.

    Step 7

    refresh the it and check it in the Rsa3 t code you can find your field visible.

    Hope this will solve your problem

    santosh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 18, 2009 at 05:54 AM

    Hi,

    you need to Check bellow Two Steps:

    A). you have enhanced the filed to datasource and activated. But you need to follow bellow steps:

    1. Goto RSA6.

    2. Select your Datasource .

    3. Select the Display.

    4. Select tick mark of the Field under Selection column of Datasource.

    5. Save and Activate.

    6. Check the data in RSA3.

    B). Once check the code in COMD from which table is populateing data.

    Replicate the datasource into BI side.

    this will help you,

    Regards,

    Suman

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 20, 2015 at 01:58 PM

    This message was moderated.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.