Skip to Content
0

NWDS for PI 7.4 doesnt load?!

Nov 22, 2016 at 02:35 PM

183

avatar image

I want to start to use iflow / familiar with nwds. I have java jre /jdk installed and have NWDS (nwds-extsoa-7.3-EHP1-SP19-PAT0000-win32.zip). Attached is version / active java's.


When I load NWDS, windows thinks about it, the java.exe shows for a moment in task manager, then closes. I see no logs of error in java or errors on screen.

What am I doing wrong?

Should I just run the latest version of JDK and uninstall the old versions?

capture.png (20.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

avatar image
Former Member Nov 22, 2016 at 03:31 PM
1

Also check the Prerequisites:

JDK version
Supported Java Development Kit (JDK) are from SAP AG or Oracle. Note that the JDK you use must be the 32-bit version. You can either use:

JDK provided with the SAP JVM 6 "Windows Server on IA32 32-bit".
You can start the installation process from here.
JDK from Oracle.
You need JDK version 1.6 (1.6.0_7 or higher), 32-bit. You can download a JDK from http://java.sun.com/javase/downloads.


Note that for deployable applications, the JDK version of the Developer Studio must be the same as the JVM version of your application server.
For more information about the Java Runtime Environment, in the Developer Studio choose Help -> Help Contents -> SAP NetWeaver Developer Studio Documentation -> Developer's Guide -> SAP NetWeaver Developer Studio Basics -> Working with the Developer Studio -> Using Different Java Runtime Environment Versions.


Prerequisites

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 22, 2016 at 03:18 PM
0

Hi George,

Uncheck 'Enabled' for 1.8 and let it run on 1.6. I think PI 7.4 is compatible with Java 7 and below.

Java 7 update 65 both 32 bit and 64 bit is compatible with:

  • SAP PI 7.01 >= SP15
  • SAP PI 7.02 >= SP15
  • SAP PI 7.10 >= SP18
  • SAP PI 7.11 >= SP13
  • SAP PI 7.3 >= SP12
  • SAP PI 7.31 >= SP13
  • SAP PI 7.4 >= SP08

Troubleshooting PI ESR and Integration Builder Logon Issues

Installing the Java Runtime Environment

Regards,

Nabendu.

Share
10 |10000 characters needed characters left characters exceeded
George Applegate Nov 22, 2016 at 04:42 PM
0

Thanks very much, I installed JRE 1.6 32 bit.. Previously had 64 bit installed.. it now works. :)

Share
10 |10000 characters needed characters left characters exceeded