Skip to Content
0

Getting an error called OLTP Still has error

Nov 22, 2016 at 01:18 PM

32

avatar image

Hello folks,

I am enhancing a generic datasource. i have add two fields VERPR and STPRS by enhancing structure. Fields are added and also given their referenced table and fields along with define currency as field in structure and activate it. But when unhinding these two fields i am getting an error called as THE OLTP STILL HAS ERRORS. Please provide me a solution on this. as i have already referred so many posts and solution providede by them on the same but not getting an exact output.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Mario Tibollo Nov 22, 2016 at 02:15 PM
0

Are the reference fields in the enhancing structure as well? They need to be.

M.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hello Mario,

Thankyou for your response. Yes I have already mentioned reference field and currency field in append structure also but not able to unhide the fields.

0

ok, just not clear in your questioni. can you post a screenshot of your enhance structure? and a the details of your error message?

0
nupur dubey Nov 24, 2016 at 07:36 AM
0

Hello Mario,

The error is resolved now. what i was doing is enhancing a generic datasource with some of the fields (VERPR, STPRS) from MBEWH table. i had mentioned these two fields in component tab using z naming convention. Also maintain their reference field in currency tab and add that reference field in append structure. I was getting error while unhiding the fields at time of datasource editing because i had not mentioned a price unit. After maintaining in this field error has gone.

Thanks & Regards,

Nupur Dubey

Share
10 |10000 characters needed characters left characters exceeded