Skip to Content
avatar image
Former Member

ODS Activation error with message "Error when assigning SID: Action VAL_SID

Hello SAP BI Gurus,

We are running into a peculiar issue when trying to activate an ODS object.

We are getting an error message "Error when assigning SID: Action VAL_SID_CONVERT InfoObject" when the ODS activation takes place. We have found that there is a record in an infoobject which is just an '!' and the SID is not generated when the activation happens.

'!' is included in the permitted character list of our BW system but still the SID is not generated for the infoobject. The settings in the ODS is set to 'SIDs Generation upon Activation'. There are other records where there is an '!' mark in between the text but not at the beginning.

Is it that SAP does not allow '!' to be individually maintained as part of an infoobject?

Any help is highly appreciated.

Thanks

Aravind Krishnan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 17, 2009 at 01:51 AM

    Hi Aravind

    This seems to be a data issue and I guess "BI general" community would have been the best choice to post this.

    You can have a look at

    Link: [Note1|https://service.sap.com/sap/support/notes/1373402]

    Link: [Note2|https://service.sap.com/sap/support/notes/1075403]

    Link: [Note3|https://service.sap.com/sap/support/notes/1162968]

    Can you please try to put "!" in the beginning in RSKC and check in RSALLOWEDCHAR table if the entry has been successfully maintained there.

    Add comment
    10|10000 characters needed characters exceeded