Skip to Content

How to get default entity display preferences applied during ERwin model import?

I have set up default general, entity, relationship, etc. settings for logical models.

Whenever I import an ERwin logical model the entity settings are not applied.

In order to apply them I need to go into the Display Preferences entity content / format tabs and click on the Default button followed by apply to "All symbols".

Not applying the desired default formatting before rendering the objects causes sizing issues that need to be corrected manually as I don't want to adjust all entities to the size of their text.

Hoping someone can guide me on how to do this or can explain why default display preferences are selectively applied.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Oct 31, 2018 at 08:35 AM

    I think the default display preferences are being overridden for individual symbols, possibly because 'themes' have been applied to them in Erwin. That'll be an attempt to make the diagrams look as much like the Erwin diagrams as possible, which a lot of people like.

    Perhaps the answer is to ensure that the symbols in Erwin all use default styles before you save the model as an XML file.

    Add comment
    10|10000 characters needed characters exceeded

    • Unfortunately themes don't have anything to do with it.

      I created a 2 entity (P-C) logical model in ERwin w/o themes, saved it in XML format, and imported it into PD with the same results.

      Unless for some reason there is a configuration problem on my side there is a definite problem w/ PD and the use of default entity display preferences.

      In PD I created a new logical model, set entity display defaults, created some entities and even that did not display properly despite having just set the defaults. Interestingly enough when I closed and re-opened the model the entities were displayed as per the default settings?!?

      I thought that perhaps this is just a display refresh issue so tried importing the ERwin model again, saving it and re-opening it but I got the same results as before. Looking at the entity display defaults it appears as though the defaults used during import are the PD installation defaults and not the ones set for the type of model being imported.

      Any other ideas?

  • Nov 13, 2018 at 05:10 PM

    Looks like a question for SAP, Jeremy

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 13, 2018 at 04:02 AM

    Hi Jeremy,

    George's answer is correct. Within the ERwin XML file the display preferences are defined and PowerDesigner will apply these values during the import process. There is no option to disable this functionality.

    Anthony

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 13, 2018 at 03:51 PM

    Thanks for the reply Anthony but I don't believe all the display preferences are being imported.

    If you look at the original ERwin eMovies model and the PowerDesigner import you'll see that: 1) the font properties are different and 2) the attribute identifier indicators are displayed in the latter and not the former.

    I even looked at the XML and there is no mention of Bold or Italic font anywhere. If you can point me to where you think the display preferences are being derived then perhaps I can modify the XML prior to importing it into PowerDesigner to get the desired effect.

    There also appears to be a display refresh issue with PowerDesigner (unrelated to ERwin imports). If I create a new logical model and set the default entity display preferences as follows:

    When I create a couple of entities with relationship only some of the display preferences are applied, despite the metadata showing what the display should look like:

    If however I simply apply the format or close / open the model the expected results are properly displayed:

    Obviously the display refresh issue is inconsequential but an interesting thing I ran across when trying to debug the ERwin import issue.


    Add comment
    10|10000 characters needed characters exceeded