Skip to Content
0
Former Member
Nov 05, 2009 at 07:06 PM

java.lang.IllegalAccessError when trying to instantiate a model

42 Views

Hi all,

In our java web dynpro project, we are using models of type "adaptative web service model".

We are using the wsdl reference to build the model.

The endpoint for each service is different in each environment DEV, QAS or PRD.

To set the proper endpoint to each service we are using the

com.sap.tc.webdynpro.model.webservice.gci.WSTypedModelClassExecutable.wdSetInvocationModifier

method to set a custom implementation of IWDWSInvocationModifier for all those web service based models.

This implementation is basically done on method

IWDWSInvocationModifier.doModifyInvocation()

.

This method makes a call to a java web service (ServiceSearcher), and this web service searches in UDDI server for the proper endpoint to be set.

This custom implementation is encapsulated in one specific DC (ServiceSearcherClient), and is working pretty fine.

The problem is that, sometimes, in another DC (Astec), when trying to execute the custom

IWDWSInvocationModifier.doModifyInvocation()

set to a web service based model, we got this error.

java.lang.IllegalAccessError: tried to access method net.weg.soa.client.servicesearcher.FindUrlResponse.createModelClassFactory()Lcom/sap/tc/webdynpro/model/webservice/gci/IWSTypedModelClassFactory; from class net.weg.soa.client.servicesearcher.ServiceSearcherModel

Actually we could not isolate the cause of this. This seems to start occurring when we deploy something by CBS (when we activate some component that uses ServiceSearcherClient).

This problem sometimes does not occur in all projects of DC Astec that uses ServiceSearchClient. Sometimes the Main project has this error, but when executing some other project (Materials, for example), it works on the same execution time. It seems that each project references an individual jar for its used DC's, and one has problem, another doesn't.

We already found that most of times this problem can be solved going to SDM, proceeding undeploy of all components of DC Astec and CD ServiceSearcherClient, and proceeding a manual deploy (with NWDS).

This has been a big problem for our team, we already spent two weeks trying to understand what is happening and our tries are ending now. Actually in PRD environment we deployed all those DC's manually with NWDS to put the system working, otherwise it does not work.

If some of you have any idea, we will appreciate.

Regards.

roberti