Skip to Content

HXE2 install fails with a core dump: dbnsutil -convertTopology

Hello,

Running the VM version of HANA Express Edition (v2.0 SP03 Rev 33) under VMWare Fusion 8.5.8 on an older Mac Pro with 40 GB of RAM and two 3.2 GHz quad-core Intel Xeon (X5482 Harpertown) running OSX 10.11.6 (El Capitan).

After importing the ova file into Fusion, I updated the VM "Hardware Version" to 12 in order to be able to address more than 8GB RAM and then updated VMs config settings to 24 GB RAM and 4 cores.

Everything works as it should until the XSA configuration step (initial login with hxeadm and password change, followed by specifying the new HANA database master password, and the question about whether I need to specify a proxy server. )

The final question is if I would like to wait for the XSA configuration to finish. I answer "Y", a summary of the config is provided and then I answer "Y" again to proceed with the configuration.

Here is where the failure occurs:

"Please wait ..."

"./.init_hxe_cfg.sh: line 887; 77662 Illegal instruction (core dumped)

/usr/sap/${SID}/HDB${INSTANCE}/exe/hdbnsutil -convertTopology >> $LOG_FILE 2>&1

Failed to change hardware key.

See /var/tmp/hdb_init_config_2018-10-24_12.18.18.log for detail."

log file only contains the same message received on the console (as above).

I have tried this with both the Server only VM and the Server and Apps VM with the same error.

I do have a working VM with the same settings based on the original HXE2 VM from back in the May 2018 timeframe running on this same machine.

My hypothesis is that my CPU is too old and does not support certain instructions it is receiving, causing a core dump.

I was able to make this work on my (much newer) MacBook Pro with the same downloaded VM.

The X5482 CPU supports Intel Virtualization Technolgy (VT-x), but not VT-x with extended page tables.

Appreciate any feedback.

Thanks,

Mike

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Oct 29, 2018 at 04:43 PM

    Hi Chris,

    Thanks for the response. I have configured the VM with 24GB and 4 cores.

    Thanks,

    Mike

    Add comment
    10|10000 characters needed characters exceeded