Skip to Content
0
Former Member
Nov 03, 2009 at 10:48 PM

Background Task running under initiator not under WF-BATCH

195 Views

Hi All,

I am trying to resolve a problem with a Background task running under intiator. Since the initiator does not have authorization to execute the task, it is not working.

My understanding was, all background tasks will run under WF-BATCH!!. Is it correct?. in 4.7, it is working this way.

However in ECC 6.00 the background task before the first dialog work item is executed under 'intiator' in this case. I have moved the same task after first dialog work item, and it was executed under WF-BATCH.. I cannot move the task after the dialog workitem as the task need to be executed immediatly after the creation of workflow.

1. How can I run the task in backgroud under WF-BATCH?

2. Inside the task, I am running a BDC to update a flag in downpayment transaction created using F-47. How can I run the process under batch user to overcome the authorization issue that initiator will not authorization.

I am running this workflow in SAP ECC 6.0 level 13

Any help is really appreciated..

thanks in advance for your help.

johnson