Skip to Content
0
Former Member
Nov 03, 2009 at 05:52 PM

Problem running crystal report

20 Views

I have wriitem a web application where I could add and run crystal reports from. Everything works in this, except couple of reports that have sql commands linked with tables. Wehn the moment I run a report that has sql commands and tables linked I get the following message.

Failed to retrieve data from the database. Failed to retrieve data from the database. Error in File Report_SQL {750813E3-30B3-4A5B-A067-5F94B0E9D01E}.rpt: Failed to retrieve data from the database.

The thing is I get this error after I pass the logon credentials and the moment I assign the crystalreportvierew control to the report document. I cannot even trap this error.

Could any one help me in correcting this? I have been working this for over a monrth and it does not work. If I run this report through a windows based .net application, everything works perfect.

And I do get this error only after I publish the web site. It works fine with the code.

Any help is greatly appreciated.

Edited by: Don Perera on Nov 3, 2009 8:18 PM