Skip to Content
avatar image
Former Member

Problems with integration process, wrong receiver service choosen

Hi

I encountered a problem with idoc messages going from SAP to integration process in PI system.

It was sent 6 idocs at the same time. Four of them went into the correct integration process, while two of them went into a different integration process and therefore failed.

How it looked in monitoring:

Msg1 -> Sender = SAP -> SenderService = SS1 -> ReceiverService = IPWrong

Msg2 -> Sender = SAP -> SenderService = SS1 -> ReceiverService = IPCorrect

Msg3 -> Sender = SAP -> SenderService = SS1 -> ReceiverService = IPCorrect

Msg4 -> Sender = SAP -> SenderService = SS1 -> ReceiverService = IPCorrect

Msg5 -> Sender = SAP -> SenderService = SS1 -> ReceiverService = IPWrong

Msg6 -> Sender = SAP -> SenderService = SS1 -> ReceiverService = IPCorrect

Setup is correct, the message is set to go to IPCorrect. Why does two messages go to wrong integration process? Does this have something to do with them being sent at the same time?

regards Marianne

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Nov 03, 2009 at 12:19 PM

    Did u have any conditional Rx determination?? Based on those conditions, it would have been routed to different Integration processes.

    Regards,

    Siva Maranani

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Suraj

      I have looked all over too see if this was the case, but I haven't found anything. It looks to me that when these idocs are sent at the same time, PI somehow makes a mistake and uses a different Integration Process as the receiver.

      The "wrong" integration process was used at the same time, but for a different message of course...Could it be some mix-up in the processing here, that PI thought it was supposed to use IPWrong instead of IPRight and if so, is it possible to avoid that somehow..?

      regards Marianne