Skip to Content
avatar image
Former Member

Idoc partner type LI to File Scenario.

Hello Experts .

I have the following scenario.

IDOC partner type LI to xml (file).

So we are not atlking about logical system here and we may have to use parties.

But I am not sure as to how to go about this approach.

For now we have Idoc coming into XI but failing after that .(Outbinding) error in reciver agreement (not to be confused with a cache issue .).

But I understand it is because of the parties not defined properly.

So I have defined a party and assigned my ECC system to the same.File was basically a service.Do I need to define another party for it or several other identifier

Tried to follow How Tou2026

Sample IDoc-XI

Scenarios document but it is to confusing.

Kindly help

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Nov 03, 2009 at 06:19 AM

    Hi Deepak,

    New to parties 😊

    Well it is simpler than it looks.. so you are getting idocs from sender ECC system and the partner profile they use is LI?? then you need to create a party in PI. You can have any name for the party (but preferably to follow naming convention)

    Now when you create a party PI adds a default row to the identifiers. In addition to that you need to add your Agenc, Schema and Name

    Agency : <SAPSID><CLNT>

    Schema : ALE#LI

    Name : <partner profile number> <eg 0000010001 (it shoudl be 10 digits long)

    Now add the business system in this party and configure your scenario normally

    Regards

    Suraj

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Deepak,

      Look at the error:

      >>No receiver agreement found for sender -DMGCLNT400 to receiver Sender_Party-,urn:sap-com:document:sap:idoc:messages.Z_DELL_PO.ORDERS05.Z_DELL_POX

      I guess it was not able to find your sender party. What you need to do is in SXMB_MONI, got through each soap header->main so that you can see where the problem is. the Main should have your sender party and service and interface mentioned correctly for your interface to work.

      Regards

      Suraj