Skip to Content
0
Former Member
Nov 02, 2009 at 08:35 AM

HTTP 401 error while connecting SAP PI 7.1 with SOAPAdapter

91 Views

Hello,

I am trying to call webservice on R/3 system using SAP PI 7.1 but I am getting HTTP 401 error.

Following is the error for more detail:

Message: Server returned error code = 401 for URI : http://sapxx03x:50000/XISOAPAdapter/MessageServlet?channel=:BS_xxxxxxxxxxx_50:CC_xxxxxxxxxxxxx_WSDL_Sender.

same url when I use with SAP XI 3.0 it works fine. It is only giving problem with PI 7.1

I know this issue is related to authentication but what problem I am facing is how to pass the credentical with the url to

resolve this authentication issue? Are there any settings I am missing? or Any other way of doing it?

I have already tried following things to resolve this issue:

1. tried giving user id & password in URL but still having same error HTTP 401.

2. tried one of the SAP note (891877) regarding Netweaver Administration to change ROLE settings but problme still persist.

3. Checked SAP Help settings

4. Did changes to web.xml file to comment the security part and restarted the system

But, Problem still exist.

Please let me know what will be the solution for this issue.

Thanks,

Anand