Skip to Content
avatar image
Former Member

NIEHOST_UNKNOWN

Hello,

I am installing BI, NW04s-SR2. I get an error at the phase 22 of 42 'Start central servive instance'. Retry and repeat the process give same error.

So far i check following isues; How can i solve the problem? Help please?

1 - ping to server is fine.

PING RMTSYS(YLDZBWT)

Verifying connection to host system YLDZBWT at address 192.168.0.6.

PING reply 1 from 192.168.0.6 took 7 ms. 256 bytes. TTL 64.

PING reply 2 from 192.168.0.6 took 0 ms. 256 bytes. TTL 64.

PING reply 3 from 192.168.0.6 took 0 ms. 256 bytes. TTL 64.

PING reply 4 from 192.168.0.6 took 0 ms. 256 bytes. TTL 64.

PING reply 5 from 192.168.0.6 took 0 ms. 256 bytes. TTL 64.

Round-trip (in milliseconds) min/avg/max = 0/1/7.

Connection verification statistics: 5 of 5 successful (100 %).

2 - content of the 'ms_acl_info' file; HOTS=*

3 - Securiy changed to /usr/sap -R chmod 777 *

4 - Error msgs;

[Thr 3512] Sat Oct 31 17:02:47 2009

[Thr 3512] ***LOG Q0I=> NiPGetHostByName: hostname 'YLDZBWT' not found: gethostbyname [ninti.c 320]

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:03:04 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:03:09 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:03:35 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:04:05 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:04:35 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:05:05 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:05:35 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:06:05 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:06:35 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:07:05 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:07:34 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:08:04 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

[Thr 3512] Sat Oct 31 17:08:35 2009

[Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

Best regards

Ibrahim Gurbuz

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Nov 01, 2009 at 09:45 AM

    Hello,

    If it helps i wound error logs. Is there any advise?

    startsap.log;

    SAP-R/3-Startup Program Rel 700 V1.8 (2003/04/24)

    -


    Starting at 2009/11/01 09:01:35

    Startup Profile: "/usr/sap/BWT/SYS/profile/START_SCS01_YLDZBWT"

    Update local Kernel Files

    -


    (2457) Local: /usr/sap/BWT/SYS/exe/run/sapcpe name=BWT

    (2456) Failed!

    (2456) system(/usr/sap/BWT/SYS/exe/run/sapcpe name=BWT) returns 255

    (2456) Return-Code 255 in Local-Kernel-Update. See sapcpe.log.

    Execute Pre-Startup Commands

    -


    (2458) Local: /usr/sap/BWT/SYS/exe/run/cleanipc 01 remove

    (2456) Okay!

    (2459) Local: CLRLIB LIB(R3WRK01)

    (2456) Okay!

    (2460) Local: /usr/sap/BWT/SYS/exe/run/sapmscsau pf=/usr/sap/BWT/SYS/profile/BWT_SCS01_YLDZBWT -n

    (2456) Okay!

    Starting Programs

    -


    (2456) Spawning program "/usr/sap/BWT/SYS/exe/run/msgserveru pf=/usr/sap/BWT/SYS/profile/BWT_SCS01_YLDZBWT" asynchronously...

    (2456) Okay, child's pid=2463.

    (2463) Starting: local /usr/sap/BWT/SYS/exe/run/msgserveru pf=/usr/sap/BWT/SYS/profile/BWT_SCS01_YLDZBWT

    (2456) Spawning program "/usr/sap/BWT/SYS/exe/run/enserveru pf=/usr/sap/BWT/SYS/profile/BWT_SCS01_YLDZBWT" asynchronously...

    (2456) Okay, child's pid=2464.

    (2464) Starting: local /usr/sap/BWT/SYS/exe/run/enserveru pf=/usr/sap/BWT/SYS/profile/BWT_SCS01_YLDZBWT

    (2456) Spawning program "/usr/sap/BWT/SYS/exe/run/saposcol" asynchronously...

    (2456) Okay, child's pid=2465.

    (2465) Starting: local /usr/sap/BWT/SYS/exe/run/saposcol

    (2456) Waiting for Child Processes to terminate.

    (2456) **** 2009/11/01 09:01:37 Child 2461 terminated with Status 0 . ****

    (2456) **** 2009/11/01 09:02:02 Child 2465 terminated with Status 0 . ****

    sapcpe.stdout;

    Could not load program sapcpe:

    Symbol resolution failed for sapcpe because:

    Symbol o4_getpwuid (number 209) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4_getpwnam (number 210) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_status (number 211) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol p_o4trc_verbose (number 212) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol p_o4trc_argv (number 213) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol p_o4trc_emar (number 214) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol p_o4trc_env (number 215) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol p_o4trc_level (number 216) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_level (number 217) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_emarfilt (number 218) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_init (number 219) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_uc_cnv (number 220) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_uc_var (number 221) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_trace (number 222) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_on_error (number 223) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_ascii_var (number 224) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Symbol o4trc_safeprintfU (number 225) is not exported from dependent

    module /usr/sap/BWT/SYS/exe/run/os4apilib.so.

    Examine .loader section symbols with the 'dump -Tv' command.

    best regards.

    ibrahim gurbuz

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Thomas Obermeier

      Hi Thomas,

      The latest SAPEXE and SAPEXEDB kernel package #221 solved the inconsistancy kernal. The error msgs of the startsap disapeared. But still i have NIEHOST_UNKNOWN problem.

      Thanks very much.

      Best regards.

      Ibrahim Gurbuz

  • Nov 02, 2009 at 12:05 PM

    > [Thr 3512] Sat Oct 31 17:02:47 2009

    > [Thr 3512] ***LOG Q0I=> NiPGetHostByName: hostname 'YLDZBWT' not found: gethostbyname [ninti.c 320]

    > [Thr 3512] *** ERROR => MsIAttachEx: NiBufConnect to YLDZBWT/3901 failed (rc=NIEHOST_UNKNOWN) [msxxi.c 652]

    Edit your hosts file and enter the server name, then retry.

    Markus

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 09, 2009 at 09:46 PM

    Had similar problem when starting from sapmmc. My Network lookback connection was disabled; I enabled this. I tried re-starting; Got same problem. I stopped from sapmmc and restarted the server. it started well. I think the cause of this problem for me was because the network (lookback) address was not working as at when I started earlier. Hope this helps

    Add comment
    10|10000 characters needed characters exceeded