Skip to Content

SAP Business One and Moving Database Issue

We are in the process of moving our PROD system to a new server. The server runs MS SQL 2005. We installed SAP Business One and by default the demo databases went to the C Drive (C:/Program Files/MS SQL Server/..../Data). The SQL Server that exists has data on D partition and logs on E partition. We therefore dettach the database, copy the files to the correct locations, and reattach.

Now, however, the SAP Business One application no longer finds the Company or Demo databases. Is there any way to fix this?

Cheers John

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Oct 29, 2009 at 11:57 AM

    you should post your question in the Business One section at SAP Business One Application

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 29, 2009 at 01:13 PM

    Moved to Business One Core forum...

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 10, 2009 at 06:14 AM

    Answer lies in the server role that the database login retains. By changing to sysadmin the account will see the database. Public will not suffice.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.