Skip to Content

Replicating B2BCustomer from ERP to Hybris Commerce Cloud

Hi Team, We are trying to implement the B2B customer replication scenario from ERP to Commerce cloud. Settings in ERP and CPI are done. And also we have done the configurations of addon extensions required for SAP ERP integration. When we trigger customer from BD12 in ERP its getting success in CPI and in CPI the respective IFlow is also successfully completed. But we re unable to receive any data in Hybris commerce system. Could you pls specify how the receiver end URL has to be configured for now, we have tried with local IP address "https://(localIPAddress):9002/odata2webservices/InboundB2BUnit/" and also with local host "https://localhost:9002/odata2webservices/InboundB2BUnit/" but couldnt get the debugging point also in the local hybris server instance. In SAP WIKI blogs its mentioned as local host url of the local server system but can you make it clear. Thanks, Swadini S +91 9894978942

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Apr 02 at 03:38 PM

    Hi Swadini

    I have the same scenario, in mi case the URL is:

    https://backoffice.civt2y-XXXXX.commerce.ondemand.com/odata2webservices/InboundB2BUnit/

    But I have the following error:

    com.sap.it.rt.camel.aggregate.exception.AggregationStrategyException: com.sap.it.rt.camel.aggregate.exception.AggregationStrategyException: Error occured while creating xml at XML: No nodes matching source XPath //B2BUnit found. Make sure you provided a valid XPath and namespace declarations(if any) appropriately including default namespace., cause: com.sap.it.rt.camel.aggregate.exception.AggregationStrategyException: No nodes matching source XPath //B2BUnit found. Make sure you provided a valid XPath and namespace declarations(if any) appropriately including default namespace.

    I looks like is missing GET from BD Hana in the iflow, did you have the same issue?

    Best Regards.

    Cesar Mejia

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 10 at 09:14 AM

    Hi

    I also have same issue. Did you solve it?

    Add comment
    10|10000 characters needed characters exceeded