Skip to Content
avatar image
Former Member

VC iView Communication error

Hi,

We have transported VC models, iview, par from DEV to QA. When trying to preview the VC report we see the report but the whole page is grayed out and error popped with message

A communication error has occurred: [FaultEvent fault=[RPC Fault faultString="HTTP request error" faultCode="Server.Error.Request" faultDetail="Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032"]. URL: /irj/servlet/prt/prtrw/prtroot/com.sap.visualcomposer.vcbroker"] messageId="AD3E8CB1-5FA5-2F11-2DC6-997B97D49BA2" type="fault" bubbles=false cancelable=true eventPhase=2]

After I click ok on the popup window, any event on the report again brings up this error popup window.

Any info on what is the fix?

NOTE: You may notice the above error message with strike please ignore it.

Thanks

Siva

Edited by: Siva Vummiti on Oct 28, 2009 5:52 PM

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Oct 28, 2009 at 07:54 AM

    Hi Siva,

    Have you check this thread?

    A communication error has occurred: An XML element was malformed

    Regards

    Basheer

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 29, 2009 at 05:07 PM

    HI,

    In the portal system administration, Check the connectivity to the data-services you are using, and that the same system alias that you used in the model (on QA), is defined in the DEV machine.

    it sounds like you have a general connectivity issue , rather than a VC issue.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Thanks everyone for your information. The issue is resolved.

      There is a bug in IE 6 and 7 or even earlier versions of IE that loading XML files in Flash over an SSL Connection in Internet Explorer fails if the Pragma:no-cache or Cache-control:no-cache HTTP headers are set on the XML file. If you looked at your HTTP header stream and if you see above cache in the header the loading of flash will fail. If you try with firefox browser or IE 8 you won't get error message. This is only in IE 7, 6 and may be earlier versions bug.

      The resolution is to check J2EE server of BI portal for following parameters

      DisableDynamicCaching = false

      NeverCompress setting for shockwave/flash

      Hi Rochelle try above settings and more explanation of never compress for shockwave/flash means,

      Disable the automatic compression of Flash objects, it seems that the J2EE is trying to compress them before sending them to the user, which is actually resulting in LARGER chunks being sent, and the application is actually working harder than it needs to

      Change would be to add the following J2EE config to exclude mimes of type u201Capplication/x-shockwave-flashu201D being compressed by the BI Portal J2EE engines

      VA ? GLOBAL --> Server --> Services --> HTTP:

      NeverCompressed=xxxxxxxxxxx, application/x-shockwave-flash,[unknown]

      i.e

      NeverCompressed=.zip,.cs,.rar,.arj,.z,.gz,.tar,.lzh,.cab,.hqx,.ace,.jar,.ear,.war,.pdf,.gzip,.uue,.bz2,.iso,.sda,*.sar,image,application/x-compressed,application/zip,application/x-gzip,application/pdf,content/unknown,application/x-shockwave-flash,[unknown]

      This will mean that flash objects are sent as is with no J2EE chunking or compression

      The above settings has resolved the issue.

      Thanks

      Siva

      Edited by: Siva Vummiti on Nov 5, 2009 4:59 PM

      Edited by: Siva Vummiti on Nov 5, 2009 5:02 PM

  • avatar image
    Former Member
    Nov 05, 2009 at 06:04 AM

    Resolved by myself.

    Add comment
    10|10000 characters needed characters exceeded