Skip to Content
0
Former Member
Oct 21, 2009 at 01:55 PM

Data Transfer Port ranges in FTPS with SSL in File Adapter

121 Views

Hi,

I would appreciate if you could give me pointers reagrding the below issue.

We are on XI 3.0.

For one interface, I have to configure the FTP File adapter to pick up the files from external server.

The connection is secure and should be FTPS with SSL.

I have the certificate from the 3rd party and have it installed on our XI development server.

The change has been made in our firewall to allow the connection to the host IP and port 21 which is configured at the target party as Explicit FTPS port and they have allowed access to our Server IP in their firewall.

I have configured other FTPS connections and they worked fine but this is the only one that has been giving me so much trouble.

The error i get today is:

Error occurred while connecting to the FTP server "60.234.48.106:21": java.net.SocketException: Connection reset

Yesterday, i got the below error:

Error occurred while connecting to the FTP server "60.234.48.106:21": iaik.security.ssl.SSLException: Server certificate rejected by ChainVerifier

The Vendor has suggested to get the firewall ports 21 and 28000:30000 (data transfer) to be opened.

He has also provided with the certificate passphrase additionally to the user name and password needed to make the connection.

When i tried the connection from the XI development to the vendor server, via the Telnet, it looked like it worked.

Please advice.

Regards,

Archana