Skip to Content

setting up integrated planning with Excel for COPA revenue accounts

We do our revenue planning in COPA and our expense planning in CO. This was all set up prior to me starting at this company. I have now been asked to update the revenue planning template to include a new characteristic. From what I can see, I can create the planning layout, but I am having issues tieing it to the file description. I am getting error message DUE010. I have tried looking on the CO side for the original template, but I am not finding it there, and the new field/characteristic exists only in COPA.

Any help in setting this up would be appreciated.

Kim

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 21, 2009 at 10:51 AM

    Dear Kim,

    I believe you are using a mixture of old and new transactions:

    - in release 4.5B using the Excel-Integration is only possible via

    planner profiles: in transaction kp34er you set the flag for Excel

    integration and there you can also save the file description. For

    the upload one has to use transaction ke13.

    - in later releases transaction kp34er still exists but should not be

    used. You can set the flag for the Excel-Integration now in KEPM in

    the parameter set. Starting the manual planning you can navigate from

    the overview screen to the customizing mode

    via menu: settings -> formatting. Then the system is in customizing

    mode (as in kp34er) and you can save the file description etc.

    For the upload one should use transaction ke13n!

    In the two procedures the system generates different names for

    the file description:

    - release 4.5B: the file id contains some concatenated fields:

    subclass (technical field for planning processor) is 02 for CO-PA

    tabname something like ce1xxxx where xxxx is operating concern

    planner profile, position in planner profile and layout name

    - release 4.6B for CO_PA: the field for planner profile and position

    are now hard coded: _SAP and 001.

    The different fields are separated by some underscores '_'.

    So please use ke13 for Excel upload if you want to use kp34er

    planner profiles or create the file description via KEPM as explained

    above and use ke13n for the upload. Please consult also the

    documentation about the Excel-Integration; there you find also

    additional information that may be useful to avoid some common traps

    and pitfalls.

    Also read the attached note 319713 very carefully

    You can try the foll steps:

    - delete file description for relevant planning layout as described in

    attached note 319713 part 5A ( this will make sure that newly

    generated file description will up to date )

    - execute planning layout either by tx: KE11 or by tx: KEPM (preferred)

    with activated excel integration flag and save file description and

    generic file name info ( if necessary )

    - make a local copy of Excel sheet used for planning of data

    - plan your offline data in this Excel sheet

    - as soon as you will finish offline planning, transform Excel sheet

    file with entered data to *.txt ( or *.csv ) file

    - perform excel upload, where as source file for upload will be used

    file *.txt or *.csv created in previous step

    - check data after upload

    regards

    Waman

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 28, 2009 at 02:45 PM

    Thank you SO much. Your answer fixed my issue and now I am uploading data into SAP for COPA revenue. My users will be VERY happy.

    Thanks again.

    Kim

    Add comment
    10|10000 characters needed characters exceeded