Skip to Content
0

web intelligence query stripping

Nov 21, 2016 at 04:01 PM

136

avatar image

i find query stripping property of web intelligence is greyed out . i am using BO 4.1 SP6 and relational universe as source. inputs on if it is supported in the version that i use and how can be of great help.pls do share your knowledge on this

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Mahboob Mohammed Nov 21, 2016 at 04:19 PM
0

Hi Naveen,

Please enable Query Stripping in the universe first, I don't know if that's the reason why its grayed out in the report. To enable it in the Universe (IDT), launch IDT and Open the Business Layer -> click the name of Business Layer on top of folders and objects -> go to its Query Properties -> Query Options -> check Allow query stripping. Save and Publish the Universe. After that, check in Webi if its still greyed out.

Thanks,

Mahboob Mohammed

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Mahboob ,

i have enabled query stripping in IDT still it was greyed out when i open my report in my web intelligence rich client in design mode and check for the property

0

Hi Naveen,

Query stripping for Relational data sources is available starting BO 4.1 SP8, which you don't have. Check out the Section 2.9.9 on page 23 in this below pdf. (text from the pdf is pasted here as well)

What's new in BO 4.1 SP8

2.9.9 Query stripping (new for relational universes)

"Query stripping is now available for relational universes (including universes on SAP HANA) as well as OLAP universes. Query stripping is a reporting feature that can be used to optimize performance by automatically rewriting the query to retrieve only objects included in the report. It is used only by SAP BusinessObjects Web Intelligence. For relational universes, you must activate the option to allow query stripping in the business layer. For OLAP universes, query stripping is active by default."

Thanks,

Mahboob Mohammed

1
Sasi Vemulapalli Nov 21, 2016 at 07:57 PM
0

Hi Naveen,

You need to enable both Query level property and the Document level propertythen the Query will be stripped. Otherwise, the Query will not be stripped.

Please find the below link for detailed info.

https://wiki.scn.sap.com/wiki/display/BOBJ/Optimize+query+with+Query+Stripping+in+Web+Intelligence

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi sasi vemulapalli,

i am not even getting query stripping option at query level and at document level it is greyed out. i have enabled query stripping at universe level

0
AMIT KUMAR
Nov 22, 2016 at 01:56 PM
0

After enabling in business layer ,goto the webi queries properties and tick the check box "enable query stripping" and see.

Share
10 |10000 characters needed characters left characters exceeded
Sasi Vemulapalli Nov 26, 2016 at 03:12 PM
0

Hi Naveen,

Do you still have the issue ?

Share
10 |10000 characters needed characters left characters exceeded
naveen raju Nov 22, 2016 at 02:45 PM
0

Thank you mahboob mahammed

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Naveen,

Mark the question as answered for better visibility, if it's answered/you're satisfied with the answer.

Thanks,

Mahboob Mohammed

0