Skip to Content
avatar image
Former Member

SRM Error - Budget Almost Exhausted - Availability Control

Hi All,

We are trying to use the Internal Order number(Real Order) in the shopping cart which has

estimated costs value of 25000 USD in KO02 and budget assignment of 25000 USD in KO22 and

we have Tolerance limit if the above Internal Order number is used in range 90%-129% it should

show warning and if it is used above 130% it should show ERROR.

While creating Purchase Order in SAP ECC 5.0 with the above the Interal Order number the system

works as expected but the ISSUE is when we try to use the same Internal Order in SRM 5.0 (classic scenario)

while creating shopping cart for value above between 22,500 USD to 25,000 USD (which is around 90%-129% of total value

25000 USD), the SRM system is throwing 2 hard ERROR messages(instead of Warning messages).

Error Messages are :1. Availability Control

2. Item XXX Order XXXXXXXX Budget Almost Exhausted

Experts any hints to resolve this issue is highly appreciated.

Thanks in Advance

Noor

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 28, 2009 at 06:47 PM

    Hi

    Implement any one of the OSS note 1062652 or 1327400, depending upon your SP level.

    R/Reddy.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi ,

      Forgot to mention that I already tried BBP_MESSAGES_BADI and BBP_CHECK/Change Badi's to change

      the messages from Error to Warning in SRM. Since the Messages are coming from SAP backend for

      account assignment details it is not visible(or dont have control over it) in Badi's incoming message parameters.

      Any other clue ?

      Thanks

      Noor

  • avatar image
    Former Member
    Oct 12, 2009 at 10:58 AM

    Hi,

    Please deselect check box ' Display Back-End messages as Errors' in the following path,

    SPRO > SAP Supplier Relationship Management >SRM Server > Cross application basic settings >Activate Extended Classic Scenario.

    With the above setting, back end messages won't display in SRM.

    Regards,

    Chandolu Ramesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Sorry I was unable respond back to you for a while.

      As per your directed SPRO path , I do not see the checkbox to disable the SAP error messages

      Can you please verify the path. We are in SRM 5.0 and ECC 5.0 Classic scenario.

      Thanks

      Noor