Skip to Content
avatar image
Former Member

Cannot connect to Livecache after restore

Hi

I am creating a sandpit SCM 5 system from our DEV instance, I have installed SCM and livecache, version 7.6.02, i've followed OSS notes 457425 & 129352 for recovering the DB (initialise) from the source backup, all worked ok, I then disconnected, when I tried to reconnect, it will not allow connection, giving the error :

Error! Connection failed to node (local) for database DLC:

-24950,ERR_USRFAIL: User authorization failed

the passwords work on the source system ok for control and superdba, would these have been reset during the initialisation/restore ?

Is there anyway to reset the user passwords when you cannot connect to the DB via DBMCLI? I have the same problem using the DBMGUI.

Thanks,

Paul.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Oct 07, 2009 at 04:38 PM

    Hello Paul,

    -> For this case it's better to create the SAP ticket to the component BC-BD-LVC, so we could login to the liveCache server & check the issue.

    -> What dbm user/password did you use to create the DLC database instance.

    Did you use the option with initialization of the database parameters from the backup?

    The SYSDBA user/password will be taken from the target database instance & as pointed at the end of 457425 note < 3. > the system tables need to be reloaded with SYSDBA user/pwd of the source database. At that time the UPC containers will be updated.

    Thank you and best regards, Natalia Khlopina

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Paul,

      -> Did you create the SAP ticket, where this problem is reported?

      -> You wrote :

      "I have installed SCM and livecache, version 7.6.02"

      ? What password did you select for the DBM user at that time ?

      DBM user of the liveCache by default SAP installation is control.

      "this time I will not disconnect before updating the system tables :)"

      It will NOT solve the reported problem.

      " i've followed OSS notes 457425 & 129352 for recovering the DB (initialize) from the source backup"

      To get clear on the problem please let me know what steps did you run from the note 457425 & what users/passwords did you specified.

      Did you run Initialize the database instance, use current parameters at Parameter Initialization step,

      then create instance for recovery?

      Or did you connect to the database & run recovery with initialization?

      -> The correct procedure to uninstall the database software is described in SAP note 599129.

      To uninstall the livecache as recommended in this note the database instance has to be dropped,

      and you could not connect to the database instance currently.

      Do you have another database instances installed on this server?

      Please post the output of the command ::

      dbmcli -s inst_enum

      dbmcli -s db_enum

      xinstinfo

      sdbregview -l

      It will be easier just to create the SAP ticket.

      To solve the reported issue, you don't need to uninstall the livecache.

      Thank you and best regards, Natalia Khlopina

  • avatar image
    Former Member
    Nov 03, 2009 at 03:50 PM

    I performed an initialiae database instance on the DB and restore parameters from backup, this solved the user problem.

    Thanks for your help.

    Add comment
    10|10000 characters needed characters exceeded