Skip to Content
author's profile photo Former Member
Former Member

Extraction check - reset initializaton

Hello all,

I am using the extraction check (RSA3) for datasource 0CFM_INIT_POSITIONS. When it has been run with the updatemode "I" and selection TR_ACC_CODE "1000", VALUATION_AREA "002" , and I then subsequently try to re-run the check I get the error message:

"No initialization with InfoSource 0CFM_INIT_POSITIONS and selection TR_ACC_CODE 1000/VALUATION_AREA 002".

,and that:

"The position initialization (InfoSource 0CFM_INIT_POSITIONS) has already been run with the selection TR_ACC_CODE 1000/VALUATION_AREA 002 ."

It is suggested that I "reset the position initialization for the selection TR_ACC_CODE 1000/VALUATION_AREA 002."

But how do I do that?

Your help is much appreciated.

Thank you!

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Posted on Oct 07, 2009 at 12:55 PM

    To reset the initialization, you need to delete the existing initialization. for that goto infopackage under your infosource and under schedular you will find a option "Initialization Options for source system". Delete this and re-run the infopackage to re-initialize.

    I did not understand why you want to reset. Try running RSA3 in "D" (delta) mode and see if you are getting any data then your init is fine.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 07, 2009 at 02:01 PM

    Hello

    Thank you for your swift reply Pravender . I did try a delta update, but here is the error message I get:

    "DataSource 0CFM_INIT_POSITIONS does not support delta update"

    So my best guess is that I need to somehow delete the intialization.

    I did delete the request on the infoprovider, but where do I find the schedular and the "Initialization Options for source system" option? On the infopackage underthe tab Schedule, I can only find schedule options. no "intialization options..."

    Thanks again 😊

    Edited by: Roger Henriksen on Oct 7, 2009 4:02 PM

    Add a comment
    10|10000 characters needed characters exceeded

    • If the datasource does not support delta then initialization is of no use. You need to pull data as full update only.

      The option i mentioned will be available in infopackage. schedular (In Main menu).

      its not available in tab. when you will open the infopackage -- in the main menu Schedular , Edit, Goto ....all you can see (at the top)

  • author's profile photo Former Member
    Former Member
    Posted on Oct 07, 2009 at 02:22 PM

    Hi,

    The datasource 0CFM_INIT_POSITIONS does not support delta. You have to do full load only.

    You can decide whether the datasource supports delta or not in the following way.

    go to RSA6, find the datasource 0CFM_INIT_POSITIONS. Click on display, you will get the datasource maintainence screen.

    In this screen, in the extraction column (above the DS fields), there is an option Delta Update. When this option is ticked, then the Datasource supports delta, other wise it wont.

    This is common for all datasource.

    Regards,

    Rama Murthy.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 07, 2009 at 02:27 PM

    Well the data source 0CFM_INIT_POSITIONS is ment for the initial load. There is a separate datasourse 0CFM_DELTA_POSITIONS for the changes to the positions. I am trying to use 0CFM_INIT_POSITIONS for the initial load using upload "I". Then, as I mentioned Ialso tried the delta upload on 0CFM_INIT_POSITIONS as you suggested, but this is where i get an error message that D is not available for tis datasource. So I am back to reseting he initializaton.

    I did just find the option "Initialization Options for source system" on th infopackage, but is is not available (in gray). So I am working to activate the option. Don't know why it is not available.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      You are seeing the option in Scheduler tab of the infopackage. This option becomes active when datasource supports delta only. 0CFM_INIT_POSITIONS is a Standard datasource and it wont support delta.

      Here the description of your datasource is CFM: Initialize Position, but it wont support delta. you have to do full load only for this datasource.

      Also, the datasource 0CFM_DELTA_POSITIONS supports delta as delta update option is ticked for this datasource.

      For example, go to RSA6, choose the datasource 0MATERIAL_ATTR and display. you can find tick mark for the Delta update option. This supports delta. For such datasources, you can do initialization and delta.

      Hope this helps.

      Thanks,

      Rama Murthy.

  • author's profile photo Former Member
    Former Member
    Posted on Oct 07, 2009 at 04:32 PM

    Hi,

    0CFM_INIT_POSITIONS is supposed to be a one-time load, yes, that's why it is not delta marked. I cannot mark it as delta load in RSA6. It will not allow me to do so in dt mode

    So this must also mean that I cannot reset the load once I have run an extraction check once with the particular selections. So how can one reset the initial load then? Any ideas?

    By the why, in the infopackage, I am not even allowed to do "full update", but rather "generate initial status".

    This is all confusing, the business content should be more easy to work with.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.