Skip to Content
avatar image
Former Member

Data Object cannot be opened / accessed error - help required

I am running a CR 2008 and have a report set against a SQL view linked via a ODBC link. The view however has been updated and now includes an extra field, which I need to add into my report.

When I use the Set Database Location to update the link I get an error message advising "Data Object cannot be opened/accessed". I click OK to this and then get a further error "Unknown Database Connector Error".

Also, when I go to refresh the report I get this error "The database table "..." cannot be found. Proceed to remove this table from the report?" - if I click no the report refreshes correctly anyway, so it must be able to connect.

I have also tried refreshing the fields in field explorer too, but the extra field doesnt appear.

Any help would be gratefully received.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Oct 07, 2009 at 09:24 PM

    Have you tried to create a brand new report out of this view?

    If yes, does it bring all objects?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Don Williams

      I can connect to the view via a new blank report and the missing field appears. However when I go to verify database it says the database cannot be found. It asks me if I want to remove it from the report, I select No then it tells me the database is uptodate.

      Via the set database location it gives me the error in the initial post.

      I think I have a workaround in that if I add a new database table to the same sql view the extra field is in there - so I will manually have to go though the report and change each formula, running total, group, and record selection from the original to the new table, then remove the old table.

      Frustrating but it does appear to work.

  • Oct 08, 2009 at 04:19 PM

    Great... that was my next suggestion. Sometimes reports get corrupted and the only to fix them is to re-build or do what you are doing.

    Add comment
    10|10000 characters needed characters exceeded