Skip to Content

Problems changing default theme

Hi,

I have created a new Portal theme using the theme editor.

Permisions is defined in the path:

System Administration / Permissions / Portal Permissions / Portal Contend / Themes

The theme is addee to the object Default Portal Desktop in the path:

System Administration / Portal Display / Portal Contend / Portal Users / Standard Portal Users

To the Default Portal Desktop object is assigned frameworkpages and various themes. I open the object, mark the the theme i want and select "set default", the checkmark moves correct, but when I save I receive the message:

"The desktop ID entered already exists. Enter a unique desktop ID. "

Please help - I just change an existing object, not creating a new?

We runs Netweaver 2004s, 7.0 SP14.

Thanks,

Finn

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 02, 2009 at 03:42 AM

    Hi Finn

    Just open your Desktop and click on "Refresh" button and then select the radio button beside the theme and then click on "Set Default" button and then click on "SAVE" button.

    Regards

    Basha

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 02, 2009 at 08:25 AM

    Finn,

    You can remove the unused themes the frameworkpages from the desktop and assign the correct one and set as default.

    Also please make sure that you are editing the copy of standard frameworkpage and desktop not the original ones.

    Ram

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 02, 2009 at 01:15 PM

    Hi,

    Thank you for trying to help me.

    If I try to delete themes om the desktop I still get the error message when i tyr to save.

    It is the original desktop and when I try to take a copy i get a runtime error.

    Regards,

    Finn

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Check the trace files there should be more information about the error.

      Strange error, Did you try restarting the portal?

      Do you have enough privileges to make the changes?

      Thanks and Regards,

      Prasanna Krishnamurthy

  • Posted on Oct 05, 2009 at 06:36 AM

    Hi,

    Yes - I have restarted the portal and I have a administrator logon.

    But I have not much experience on trace logs. Can you please tell me where I find this, thanks.

    Regards,

    Finn

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.