Skip to Content
avatar image
Former Member

No response available

Hi,

this may seem like an obvious question but... here it goes anyway. PI is used to call receiver (web service) at an external company through soap channel.

Sometimes, not often, I receive errors such as

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Message entrant

-->

- http://sap.com/xi/XI/Message/30" xmlns:SOAP=" http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">

<SAP:Category>XIAdapterFramework</SAP:Category>

<SAP:Code area="MESSAGE">GENERAL</SAP:Code>

<SAP:P1 />

<SAP:P2 />

<SAP:P3 />

<SAP:P4 />

<SAP:AdditionalText>com.sap.engine.interfaces.messaging.api.exception.MessagingException: No response available.</SAP:AdditionalText>

<SAP:Stack />

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

This seems like an error at the provider...

How can I prove it to the provider ? They say the response may be lost on our side.

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 30, 2009 at 05:31 PM

    Hi Thierry,

    Try using other tools like altova xml spy or soap ui and try to send the same payload for the receiver address and see you have the same error or not. If not then it is some issue while using xi.

    Regards,

    ---Satish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 30, 2009 at 04:53 PM

    Hey

    In addition to the error message from sxmb_moni,you can configure TCP gateway or some other sniffer program which will monitor outbound SOAP messages,in most cases they give more description of error.

    Please search for blog on TCP gateway on SDN.

    Thanks

    Aamir

    Edited by: Aamir Suhail on Sep 30, 2009 11:53 AM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks,

      Any other suggestions ....

      is it garanteed that the problem is on their side if there is the message.. no response.

      Thanks.

  • avatar image
    Former Member
    Nov 03, 2009 at 09:10 AM

    Hi Thierry Dagnino,

    I am also getting this error. But in my case it is SOAP to RFC synchronous scenario.

    BizTalk calls XI web service to send data. XI then sends the data to ECC system by calling a RFC enabled function module.

    What was the cause of your error? How did you resolve it?

    I will be grateful to you if you can tell me the possible root cause of this error?

    Thanks & Regards

    Gopal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Actually,

      error may not be on server side but in the route between the server and PI. Response is lost on the way back...

      Could be server.

      Could be proxy...

      Take care.