/scripts/ahub.form.attachments.js
1

IDES developer key is not validated

Nov 20, 2016 at 07:51 PM

96

avatar image

Hi, dear experts

the problem is that I had fair and fully-functional developer key for my IDES installation, which worked just fine, but due to certain circumstances my user was locked and invalidated ("valid to" date has expired) and I lost ability to create new Z-programs.

After time, user was renewed but now the system constantly prompts me to enter developer key when I try to create something. Also I lost the key itself as it was sent to me long long ago, and my message box has self-cleaning policy. All my colleagues from the training group work as before and their keys are still functional.

What can I do in such situation? My BASIS guy is a total newbie and has no idea what to do in that case. And I has no direct access to OSS.

I checked DEVACCESS table and dev-key maintained against my user is still there, but it is invalid when I try to enter it in a prompt window. How that cold be? It was perfectly functional before and the user is still the same. How the validation is made?

I read dozens of old threads and the question is raised in a couple of them (for example here and here) but nowhere have been given an answer.

I have basic idea about the issue:

1. I know that validation is made via system call CHECK_DEVELOPER_KEY, as stated here, and this call is made in FM CHECK_DEVELOPER_KEY.

2. I know that developer keys are stored in DEVACCESS table and this table is checked when any Z-changes are made.

3. I know that the developer keys are generated using Installation number and User ID as input parameters. And if these values haven't changed, the key should be valid.

In my case all these prerequisites are met (installation number and user ID left unchanged) but the key now is not approved by system. Why?

Is this assumption about encryption of DEVACCESS table correct?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Sandra Rossi Nov 20, 2016 at 08:40 PM
0

I know that the developer keys are generated using Installation number 
and User ID as input parameters. And if these values haven't changed,
the key should be valid.

You're right. So I can't understand why you have this issue. The key logic/algorithm has never changed up to now. I didn't find any SAP note about any issue.

The developer key in DEVACCESS is not encrypted. I often copy it from an existing system, when a brand new system is setup with same installation number.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

>> So I can't understand why you have this issue.

So do I. Cannot figure out what I am missing.

0

Then you need to pass the question to SAP support.

0
Skip to Content