Skip to Content
avatar image
Former Member

WebDyn pro code doesnt call on perssing Submit button in Adobe forms

Hi all,

I am tryng to save data from Adobe form into SAP, by clicking Submit Button.

for this submit button I have selected *click event and in Web Dynpro event onSubmit written method.

to see flow I put a Break-Point inside method, when I executive this application and click on submit button

control doesn't go to the Break-Point.

can anybody help me in this.

Thanx..

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 24, 2009 at 11:42 AM

    Hi,

    1. Insert Webdynpro script in form

    T-code SFP - Utilities - InsertWebdynpro script

    2. Submit Button Drag & Drop from Library-Webdynpo Native tab

    it will work fine......

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      1) Even though I open my layout in Change mode the 'Insert WebDynpro Script' option is still inactive.

      2) As I change My Main_View 'Display Type' into activeX. form diappear on executing the application.

      3) I think there is some tool is missing at my end, please hlep in initial steps for set up.

      I have install ALD setup for adobe live cycle Disigner 7.1 and I have install ACF too on my pc.

      please tell me is it enough for this kind of application or I need to do anything extra.

  • avatar image
    Former Member
    Sep 24, 2009 at 12:00 PM

    HI,

    Check whether u have dragged and dropped WebDynpro ActiveX Submit button..

    Also check whether u hv given the property *"displayType"* in MAIN view--> Layout Tab as ActiveX.

    And if u hv any javascript coding for that Submit button, u hv to goto *Utilities--> insert scrip*.

    For this u hv to check the form is in change mode and then only u can insert the script

    Regards,

    Surya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 25, 2009 at 09:36 AM

    I am not yet getting expected result.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 25, 2009 at 10:22 AM

    HI,

    Can you tell what is happeneing when u click on submit button..? r u getting any error..?

    regards,

    Surya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 25, 2009 at 10:51 AM

    Hi Veena,

    Check whether u hv mistakenly created any other events in the layout tab of *main* view... Even if u hv created, no prob in it.. Select the event from the dropdown list.. the event shud be the eventhandler in which u hv written the code...

    if the above is correct, where u hv placed the breakpoint.. at the start or where u need..? try placing the breakpoint immediately after the data declaration and navigation code ends..

    Regards,

    Surya.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 07, 2009 at 05:50 AM

    my problem has solved after installing the ZCI layout in client PC. which was not there earlier. now Submit Button is working finely.

    Edited by: veenas on Oct 7, 2009 7:50 AM

    Add comment
    10|10000 characters needed characters exceeded