Skip to Content
avatar image
Former Member

Web Application Designer Appearing in Unicode (UTF-8)

Hello All,

I am trying to run a BW 3.x query through the Web Application Designer. The query is displayed as a hierarcy and is expanded to the key figure structure. The query runs fine in Excel and on the Web. However, when I add the query to the Web Applicaiton Designer, it appears in Unicode (UTF-8) and looks like a bunch of random characters. I can fix this my selecting View --> Encoding --> User Defined on my Internet Explorer toolbar, but I can't expect end users to have to do this as well. Does anyone know why this is happening? I have built quite a bit of reports in the WAD and have never had this problem. Also, I have several other WAD reports working that have the hierarchy display in them.

Any help would be greatly appreciated.

Thank You!

Tina

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 28, 2009 at 08:01 AM

    Hi Tina,

    Recently the same problem suddenly appeared in our system.

    All existing 3.x web templates work just fine. All newly created templates will not even show the variable screen but just show random characters. The template works when I right click in Internet Explorer and change the encoding.

    A temp. solution is to change this line in the web template:

    meta http-equiv="content-type" content="text/html; charset=unicode"

    to

    meta http-equiv="content-type" content="text/html; charset=utf-8"

    I would wish I knew where to change this globally so this would affect all new templates!

    BR

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi All,

      I've also had this problem while creating new templates in version 3.x, old templates with unicode is working fine only new have this issue.

      Changing code in web template to UTF-8 helped in my situation.

       meta http-equiv="content-type" content="text/html; charset=utf-8"

      Hope this help.

      Best Regards,

      Piotr Radzki

  • avatar image
    Former Member
    Sep 24, 2009 at 02:38 PM

    What is your IE version? Does this happen on all PCs?

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Tina,

      This has also just happened to me on an existing web application that has not been changed for a long time.

      Only a single web application seems to be effected.

      The web application displays incorrectly on all computers and is corrected by changing the encoding.

      We are using IE7.

      I can't help, but at least you know that you are not alone!

      Ian.

  • Sep 29, 2009 at 08:35 PM

    We just had this problem. It happened early last week and we havent found the solution until now. Temporary solution is to change the charset value and save while on HTML tab.

    The problem occurs only to new and existing changed web templates. Other web templates that remains unchanged were working fine even though meta tag shows charset=unicode.

    If you guys find out something that can permanently solve this problem, would appreciate if you can share.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 30, 2009 at 01:55 PM

    Our company is having the same problem. It was discovered last week and we have been searching for a solution. My question is does anyone know how this issue came about? Was it from applyng an oss note?

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      The problem occurs for the Web Application Designer 3.X on PCs where

      the Microsoft Security Patch KB956844 has been implemented. It affects

      the WAD 3.X.

      Unfortunately, the investigation by the development team has come to

      the conclusion that a fix in the Web Application Designer 3.X cannot be

      created.

      For this issue now the note 1390941 has been created. Note 1391689

      also describes some further consequences of this incompatible change

      by Microsoft.

      There are no further options than the ones described in the notes.

      Currently, we are trying to convince Microsoft to revert the change

      in the DHTMLedit control for windows based applications like the WAD

      3.X. The security problem seems to affect internet browser based

      applications. In case of any changes in this matter the notes will be

      updated accordingly.

      Best regards,

      Janine

  • avatar image
    Former Member
    Oct 28, 2009 at 01:41 PM

    Hi Janine,

    I am also facing issue with WAD templates. I happened to change two WAD 3.X templates and now when i execute , I will only see a set of notations.

    I did check my system and found that the security patch KB956844 was installed on my system recently. My question is ,will the WAD templates work as usual if I have the local IT uninstall this patch in my system?Or do we need to wait for Microsoft to revert the changes in this Patch.Please suggest.

    Thanks and Regards,

    Kavitha.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Kavitha,

      I am in the same situation and I asked our Service Provider to remove the patch which they have done. But the problem still exists, which leads me to believe the uninstall does not work effectively. Subsequently they provided a second PC without the patch installed and WAD now works fine.

      Regards,

      Ian.

  • avatar image
    Former Member
    Nov 03, 2009 at 01:28 PM

    A little bit further forward.

    Our Service Provider installed an earlier version of the file:

    triedit.dll (14 April 2008)

    in the directory:

    C:\Program Files\Common Files\Microsoft Shared\Triedit

    I am not sure if there is a registration of this DLL required.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 21, 2009 at 03:58 PM

    Hi,

    Do you know if SAP developed some permanet solution to this issue?

    I tried to view OSS notes which were mentioned earlier, but unfortunately, those notes are not longer published in OSS 😔

    Thanks in advance,

    Pawel

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Pawel,

      This is the response from our enquiries:

      As per the SAP recommendation please uninstall the security patch.

      At moment those are the possible solution that we have.

      It is not SAP bug.. It is Microsoft limitation now. That this

      restriction is from Microsoft side for the DHTML editor.

      You have to use WAD 3.x on Windows Vista only. If still you have to

      continue using it, you have to uninstall the security patch.

      I would recommend you to open a message also to Microsoft reporting

      that. Doing that may speedup them to produce the fix of Microsoft Patch

      KB956844.

      As you might imagine, our security team are not keen on removing the patch.

      Regards,

      Ian.