Skip to Content
Oct 03, 2018 at 06:09 AM

Smartfield not in Edit Mode


Hi all,

Does anyone know why I might be having trouble getting my SmartField to render in edit mode? No matter what I do, it seems to insist on being display-only. My field is bound to a property from an oData model, which has an actual SAP oData service as its data source. I do indeed have the sap:updatable attribute equal to true in the metadata for my Property. I accomplished this by setting the property's "updatable" checkbox in the EDM in SEGW.

I run my application on FLP + service /sap/bc/lrp is activated

Any thoughts?