Skip to Content
0

HANA view not correcting displaying SMALLINT data type fields

Nov 18, 2016 at 07:22 PM

11

avatar image

Hello

We are currently using SDI to connect our HANA database to a SQL server database. When we preview the data in HANA Studio, using a view, any field with data type of SMALLINT is appearing as a multiple of 256.

For example, if the value in the SQL server database is 2, then for the same field in the HANA view we are seeing 512. This is happening for all fields defined as SMALLINT.

In a small amount of cases, the result in HANA is not divisible by 256, but in these cases its still showing incorrectly. For example, in SQL server the value is 1000, in the HANA view it is -6141.

We have verified the data types are smallint in both SQL server and HANA. We have also tried using different data types in our HANA view, but that hasn't worked either.

For various reason, we can't change the data type in SQL Server. We need to fix this in HANA.

If anyone has any suggestions, that would be great.

Thanks

Charla

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers