Skip to Content
0
Sep 16, 2009 at 02:12 PM

Error trying to deploy custom adapter module to XI

13 Views

Hello... we're currently on XI 3.0 Netweaver 04. I'm currently trying to deploy a custom adapter to the J2EE engine per the variouis "How To...Create Modules for the J2EE Adapter Engine". When our Basis support uses SDM to deploy the bean we get the following error"

===========================================================================+

Deployment started Tue Sep 15 16:12:30 CDT 2009+

===========================================================================+

Starting Deployment of UM001_EAR

+Aborted: development component 'UM001_EAR'/'sap.com'/'localhost'/'2009.09.15.17.00.58'/'0':Caught exception during application deployment from SAP J2EE Engine's deploy service:java.rmi.RemoteException: Cannot deploy application sap.com/UM001_EAR.. Reason: Exception during generation of components of application sap.com/UM001_EAR in container EJBContainer.; nested exception is: com.sap.engine.services.deploy.exceptions.ServerDeploymentException: Exception during generation of components of application sap.com/UM001_EAR in container EJBContainer. (message ID: com.sap.sdm.serverext.servertype.inqmy.extern.EngineApplOnlineDeployerImpl.performAction(DeploymentActionTypes).REMEXC)

Deployment of UM001_EAR finished with Error (Duration 7690 ms)

This error doesn't tell me a lot but I was wondering if a) anyone knows what this error is typically related to or b) where can I go to get additional details regarding why SDM can't deploy the ear file?