Skip to Content
author's profile photo Former Member
Former Member

Send DOCMAS without attached files (Originals)

I need to send DOCMAS header information from one system to another using ALE. However, I have no need for the originals on the receiving system and they are causing me the error: Error while checking in and storing problem.

Is there a flag that can be set telling ALE to ignore the attached files?

I can see in the documentation for the E1DRAWM segment of the DOCMAS IDOC there are two fields:

internal data type : CHAR

Internal length : 000002 characters

Position in segment : 037, Offset : 0598. external length : 000002

ORIG1_DSTRB : Transport originals with ALE

internal data type : CHAR

Internal length : 000001 characters

Position in segment : 038, Offset : 0600. external length : 000001

ORIG2_DSTRB : Transport originals with ALE

However, I cannot find any documentation on possible values for these fields. Does anyone know?

I see from this forum post, a similar person resolved this problem in BD79. What Flag is being referred to here?

[|]

Thank you for your help.

Scott

Add comment
10|10000 characters needed characters exceeded

2 Answers

  • Posted on Oct 20, 2009 at 05:01 PM

    I'm not sure about ORIG1_DSTRB flag, but there is another solution (not so elegant though):

    you can implement EXIT_SAPLCVALE_001 exit , and remove segments related to files with this code:

    delete i_idoc_data WHERE segnam = 'E1DRAWFILES'.

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 21, 2009 at 07:23 AM

    Hello,

    We had the same problem.

    We simply used a filter on the segment E1DRAWFILES in the distribution model of the sending system (a condition on a random field of segment E1DRAWFILES that is always FALSE).

    Advantage of segment filtering, when condition is FALSE only the segment level is deleted, the header segments are created in the IDOC.

    Another solution is already explained, via the user exit delete the segment E1DRAWFILES from the master IDOC.

    Wim

    Add comment
    10|10000 characters needed characters exceeded