Skip to Content
author's profile photo Former Member
Former Member

Asset Revaluation Error in J1AI transaction

Hi,

We are in the process of revaluating assets from Sep'09 to Dec'09 for our client in South America based on the indexes.. The last revaluation in the legacy system was done in Dec'06. And this is the date that has been given in the Inflation Method we are using in the Last Reval. Date field. We are using Dep Area 02 for inflation.

For testing purposes,

1) We have maintained only one index in "Maintain Inflation Indexes" for the date 30.09.2009.

2) "Maintain Posting Variant" with 30.09.2009 to 31.12.2009

3) "Maintained Time Base and Exposure to Inflation Variants"(TBE) with the same intervals from 30.09.2009 to 31.12.2009

4) Assigned the TBE created above in the "Maintain Period Control Methods"

5) Maintained a Revaluation Key and assigned the TBE, Period Control Method and Inflation Index to the Reval Key

6) Relevant Accout Determinations and Transaction Types have been maintained.

7) "Maintain Inflation Methods" has the Last Reval Date as 31.12.2006

Problem now we have is that when we run the J1AI transaction code with the asset Value date as 30.09.2009 and fiscal year as 2009, we get an error "Execute the program for 30.09.2008 first". I am not sure why the system is looking for an year back to run the revaluatuon program first. And even when I give the date as 30.09.2008 and year 2008 to run the reval, I get the error as "Enter a valid Asset Value Date".

Can anyone help me out how to resolve this and let me know if the configuration is correct?

Thanks in advance for your help.

Raj/

Add comment
10|10000 characters needed characters exceeded

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 22, 2009 at 11:28 PM

    Please check these two points:

    1.- Review Time Base and Exposure to Inflation Variants, if you want to maintain a time exposure variant valid for every year, you can enter the year as u20189999u2019:

    Year Month Day Post Month Day Prev Year

    9999 1 31 X 12 31 X

    9999 2 29 X 1 31

    9999 3 31 X 2 29

    9999 4 30 X 3 31

    9999 5 31 X 4 30

    9999 6 30 X 5 31

    9999 7 31 X 6 30

    9999 8 31 X 7 31

    9999 9 30 X 8 31

    9999 10 31 X 9 30

    9999 11 30 X 10 31

    9999 12 31 X 11 30

    2.- Review 'Maintain Inflation Methods' option and In the u201CLast Rev. Dateu201C field, you must set the u201CFirst Dateu201D to execute revaluation instead the last date.

    Hope this be usefull.

    Regards

    Alex Puig

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 23, 2009 at 02:50 PM

    Thanks. I resolved the issue. I maintained the last revaluation date on the Inflation method as 01 Aug 2009 and according maintained an inflation index for 31.07.2009 and added 31.07.2009 in Posting variant and TBE. That resolved the issue and now I am able to run the revaluation program for 30.09.2009.

    Add comment
    10|10000 characters needed characters exceeded