Not seeing stored procedure in my connections

Hello,

I'm trying to use the Set Datasource Location to set the current data source to a different one on a different server. When I set up the ODBC (RDO) connection and expand the "Stored Procedures," my stored procedure is not visible as a choice.

We use SQL Server to manage permissions, and I imagine this has something to do with that. This case is a bit different from the usual though, as the stored procedure is actually on Schema A, but we set up a synonym on Schema B that points to it. We're expecting to see the stored procedure show up when expanding Schema B and looking at "Stored Procedures."

Are there any known limitations in Crystal that would prevent us from connecting to the synonyms?

Thank you for any assistance on this.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 18, 2016 at 06:08 PM

    Hi Bob,

    Synonyms should be working fine in Crystal. When you start Crystal Reports, go to File | Options | Database. Make sure Synonyms and Stored Procedures are checked. Also try setting something in the Table Name Like or Owner Like boxes.

    Crystal will by default only return 200 database objects so this Table Name Like and Owner Like boxes will help filter your choices out.

    Now try going into Set Datasource location and see if you can find your procedures.

    Good luck,

    Brian

    Add comment
    10|10000 characters needed characters exceeded

Skip to Content