Skip to Content
avatar image
Former Member

Web-Service Proxy and Web-Service Client access in a Bean (EJB 3.0)

Hello Community,

i want to access the SAP Knowledge-Management via the Webservice "RepositoryFrameworkWS", which resides on our Portal-System, from my Java-Application, which runs on a NW CE 7.11 Ehp1 Java Server.

I choosed to create a WS-Client as a deployable client. So i created an Bean Project, imported the WSDL and created a WS-Proxy in that project. Additionaly i added some beans to that Bean-Project which use the WS-Proxy to access the KM.

So far so good.

But the WSDL also creates a Service-Endpoint, which already has an url for the WS-Target and Authentication-Information (in my case it seems that no Authentication is active) in its body.

Because my client shell run on different systems in the future i searched for a way to easiliy deploy my application and adapt target-information elsewhere. I found in the documentation, that after deploying the deployable WS-Proxy/Client this can be done in the NW-Administrator under SOA-Management->Application and Scenario Communication->Single Service Administration.

To my surprise i found my deployed WS there. And the entry for the there listed Port was configurable. But unfortunatly this customization is ignored by the application. For example i changed authentication to a HTTP-Authentication with a specific user and also changed to Target-URL. But with no success.

What's wrong here?

i accessed the WS in my bean in the following way:

    public Class xyz
	@WebServiceRef (name="RepositoryFrameworkWS") 
	RepositoryFrameworkWS service;

      RepositoryFrameworkWSViDocument vi = service.getPort(RepositoryFrameworkWSViDocument.class);
     vi.findResources(rid,....)
     .....

regards

Matthias Hayk

Edited by: Matthias Hayk on Sep 15, 2009 10:13 AM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Sep 17, 2009 at 08:42 AM

    Hi Matthias

    In Single Service Administration there are two views: Webservices and WS Clients configurations. First of all you should enable BASIC HTTP authentication in WS configuration. Then go to WS Client configuration and enter user/password in HTTP BASIC authentication settings.

    Hope this help.

    BR, Siarhei

    Add comment
    10|10000 characters needed characters exceeded