Skip to Content
avatar image
Former Member

Error "Balance not zero: x debits: x credits: x" when RD04 MM Receipt (STO)

Hi Gurus,

Have you already seem this kind of error:

Output Type RD04 is correctly generated when the billing document is saved for Stock transfer order.

But when I checked the IDOC INVOIC, the message is "Balance not zero: x debits: x credits: x".

My idea is that this error is comming from output tax which is not correctly taking into account on Sales or Purchasing side.

I tried some adjustments on OBCA and OBCE without success.

Also I thought that the flag "Calculate tax" could be the solution.

No result.

Thanks for your help.

Stéphane.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Sep 16, 2009 at 07:07 AM

    Hello,

    I was able to solve the same issue by following OSS note 398414 - EDI: processing of tax code / tax amount

    Summary

    You want to edit an invoice via EDI. The invoice Idoc, however, runs into status "51" (incorrect). The system generates error message M8534:

    "Balance not zero: & debits: & credits: &"

    With the amount displayed as a balance, it is the tax amount.

    Additional key words

    idoc, idoc_input_invoic_mrm, idoc_input_invoic_mm, M8534, tax

    Cause and prerequisites

    Consulting

    Solution

    On the item level (segment E1EDP04) only the tax codes are read when the invoice Idocs are processed; the tax amounts are not read from these segments.

    For each tax code, a segment E1EDK04 must exist with the total tax amount for this control indicator on the header level. Thus, the tax amounts are read from these segments (E1EDK04).

    You must set the Customizing for the creation of the invoice Idoc so that the corresponding E1EDK04 segments are generated. Change this setting by using Transaction V/08. To do this you must setthe tax condition as follows: "S: Printing at totals level".

    Hope it is helping.

    Regards

    Arnaud

    Add comment
    10|10000 characters needed characters exceeded