Skip to Content
avatar image
Former Member

full qualified host name

Dear All,

We've created a web service from function module in our development server.

When we try to display WSDL, we're getting an access denied error.

http://server01:8001/sap/bc/srt/rfc/sap/Z_test_webserv

When we try to replace server01 with the actual ip address it works.

Also using server01.company.org works.

Parameter is set to

icm/host_name_full = server01

/etc/hosts

192.168.22.24 server01

I try to look at it at RZ11 but it has no option to change the value.

What will be the best way to solve this?

What will be the effect of changing server01 to server01.company.org in the hosts file?

Any help is greatly appreciated. Thanks!

Regards,

Rayel

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 11, 2009 at 03:30 AM

    After reading SAP note1164874 and 73803,

    I look up again at RZ11 and noticed that parameter icm/host_name_full is not set

    and what was displaying in smicm tcode is the actual value of SAPLOCALHOST.

    Since the value of SAPLOCALHOST is not a fully qualified host name, it

    is being ignored by ICM so I need to set icm/host_name_full explicitly.

    Is this correct?

    Still there are no options to change that in RZ11 and can't find the parameter in RZ10.

    Are there any other way?

    Regards,

    Rayel

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 11, 2009 at 04:27 AM

    Hello,

    The parameter icm/host_name_full should be set to <Hostname>.<domain-name>.com.

    Change the same in host file also.

    your web application will run on

    http://server01<host-name>.com:8001/sap/bc/srt/rfc/sap/Z_test_webserv

    Regards

    Rakesh

    Add comment
    10|10000 characters needed characters exceeded