Skip to Content
0

Enabling the Inbound Transaction Error Handling feature in Work Manager 6.4

Nov 18, 2016 at 01:04 PM

275

avatar image
Former Member

I am trying to edit and transmit a Work Order description from the device keeping the work order open in the change mode at backend, so that I can get the error 'workorder is locked by the user' in the work order inbound queue and view the queue in the SAP Admin portal(transaction code /n/syclo/admin in ECC).

Tried enabling the feature with the following configurations:

- In the configpanel, activated Inbound Transaction Management in the mobile application configuration

- In the ECC, maintained the parameter id-/SMFND/INB_TRANS (present in the configpanel Inbound Transaction Queue Definition) in the user profile.

How can I receive the transaction error in the work order queue and continue with the transmit?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

avatar image
Former Member Nov 28, 2016 at 08:38 AM
0

Please tag @mark.pe, maybe he will help you on this.

Share
10 |10000 characters needed characters left characters exceeded
Ray Isada
Nov 30, 2016 at 10:54 PM
0

Looks like you're missing a couple more steps:

  • Go back to the ConfigPanel main screen and click Inbound Transaction Queue Definition. Select the parameter in the application where you enabled inbound transaction in the previous step and check the Require User Parameter box. Ensure that the Activation Token Value field is set to ON.

  • Enable inbound transaction support in the client application logic. From the Client Globals tab, find the following client globals and set their values to either Y or keep blank:

Please refer to the WM Config Guide for further reference.

Thanks,

Ray


uym29.png (178.0 kB)
tkw3r.png (39.4 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Dec 01, 2016 at 07:06 AM
0

Hi Ray,

The above two steps are already enabled and the work order locking object mentioned in the configuration guide is also turned on in the configpanel. Still the queue is not getting created in the SAP Admin portal. Let me know if you need more details on the issue.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

I am facing the similar issue after setting up the inbound queue management configuration as described in the documentation.

Were you able to figure this out?

0

Hi Arihant,

What SAP Work Manager version you are using? Do you know what transactions you were trying to handle.

Please take a look at this to make sure it is enabled.

Client Object Locking Matrix

I would suggest you take a look at this if you have not already done so.

Working with Inbound Transactions


Regards,

Chung

SAP Product Support Engineer

0
avatar image
Former Member Dec 01, 2016 at 07:42 AM
0

@mark.pe Please provide your suggestions here

Share
10 |10000 characters needed characters left characters exceeded