Skip to Content
avatar image
Former Member

Maximum rows allowed

I know how to choose Preferences, Excel Options and change the maximum rows allowed. However, I've done this and am still having problems. My spreadsheet has 2100 rows and i've set the maximum at 5000 (I've tried several numbers) and I still get the error message "your range has been reduced to the maximum allowed rows". In preview I don't get any data at all.

I can't find any thing in the forums about this. Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Jun 06, 2012 at 05:40 PM

    I know this is an old post but I thought I would post the solution in case anyone else was trying to research this issue.  My spreadsheet contained 2800 rows and I receieve the same error as described above.  I found that when I set my Exel Options row limit in Xcelsius to 5000 it didn't work as others have stated.  However, I then cut/pasted all but about 300 rows from my spreadsheet into a blank temporary spreadsheet.  I then Previewed my Xcelsius Dashboard and it worked as expected.  However I then pasted the rows from my temporary blank spreadsheet, back into the orginial spreadsheet. I now had 2800 rows again and when I previewed my dashboard it worked perfectly!  I can't say for certain but I think by deleting the rows and previewing, it may have reset Xcelisus somehow to look at the new row count.  Strange solution I know!  🤣

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dale-

      Worked for me too, though deleting and re-entering rows was not an option because all of my data is external. I did find, though, that if I saved the project and closed the interface, then when I opened it again, the change took. Simply saving was not enough, I had to close and re-open it. Not sure why, but it was an easy work-around.

      -L

  • Sep 08, 2009 at 05:08 PM

    Rebecca,

    What is the maximum number of rows it is taking?

    -Anil

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      >

      > Hi All,

      >

      > I am using excel2003 with Xcelsius 2008 version.Even i am getting the same error

      > 'Your range has been reduced to the maximum rows allowed'

      > Is anyone aware of this error and the method to resolve this?

      >

      > Thanks,

      > Sreelekha

      Are you doing any vlookups that are using the entire column for a reference as opposed to column/rows?

  • Nov 20, 2009 at 12:49 PM

    Hi,

    same issue for me - in my charts and tables I selected a maximum range of 200 rows qhich is quite a bit less than the Xcelsius presets. I set the maximum value in the preferences to 300, 1000, ... - but no difference, the message still pops up.

    I will continue trying to find the reason for that problem - any suggestions? If I should get it to work, I will let you know that.

    Best regards,

    Michael

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 14, 2011 at 12:23 PM

    I think there's a bug here. I've set my maximum rows in preferences to 500,000. The database only has around 20,000 rows!!

    However, I am still getting this message.

    Is there any way to discover what is triggering this message? I'm not missing any data.

    I'm using Xcelsius Enterprise 5.4.0.0.

    Though this is closed I have yet to find a reasonable explanation for this solution anywhere on the SAP forums, can someone please point me in the right direction.

    Thanks

    Eddie

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 25, 2013 at 09:07 PM

    Louis, good to know.  Thanks!

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 25, 2015 at 03:26 PM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 09, 2016 at 04:41 AM

    I tried DaIe's solution but it did not work.

    But I solved this problem by removing all Sumif() functions in Excel...

    Add comment
    10|10000 characters needed characters exceeded