Skip to Content
author's profile photo Former Member
Former Member

Content Conversion - Ignore extra last fields

Hi There

My content conversion has the following:

STRUCTURE.fieldNames

STRUCTURE.fieldSeparator

STRUCTURE.additionalLastFields

STRUCTURE.endSeparator

My payload has 22 fields and I only specify 20 field names in my CC.. Due to the parameter additionalLastFields, I don't get an error because of the extra 2 fields.. These field is used in the file name and not in the file itself.. But it adds it to the end of each line regardless. I suppose adding fixed Field length would solve this problem but that I don't have.

Is there a way to ignore these 2 by NOT adding it to the file? Maybe some parameter I migth have over looked?

Thanks

Jan

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 07, 2009 at 11:20 AM

    Hi,

    Use the different structures for payload data and the fields to be used for file name.

    Similar to STRUCTURE add one more structure as STRUCTURE1 and define those 2 fields over here.

    The FCC parameters can also be dfefined accordingly.

    STRUCTURE1.fieldNames= field1, field2

    STRUCTURE1.fixedFieldLengths = 0,0

    Thanks

    Swarup

    Edited by: Swarup Sawant on Sep 7, 2009 1:20 PM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 07, 2009 at 11:21 AM

    Hi,

    Please see the "Handling Structure Deviations" Section of the below link.

    And configure the CC as specified. It will work

    http://help.sap.com/saphelp_nw04/helpdata/EN/2c/181077dd7d6b4ea6a8029b20bf7e55/content.htm

    Shweta.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 07, 2009 at 01:21 PM

    Hi,

    Do the following:

    1. In STRUCTURE.fieldNames: field1,field2....field22

    2. In your datatype, define only from field1 to field 20.

    It must work.

    Regards

    Ivan

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 07, 2009 at 01:26 PM

    hi you can try to use the parameter.

    NameA.lastFieldsOptional

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 08, 2009 at 03:35 AM

    Hi Jan,

    Please have a look at the following link and see if it helps you.

    Ignore fields in File Content Conversion

    Best Regards

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.