Skip to Content
author's profile photo Former Member
Former Member

Unable To Start SAP Crystal Addon

Hi Experts,

A few of workstations are having the following error message when we try to start the addon.

"Retrieving the COM class factory for component with CLSID {3EBB7859-E4E3-4D77-B673-C6E5AD529CC1} failed due to the following error: 80040154"

Check this forum and tried the provided solutions from this forum. Downloaded the latest version of the addon (to try) but the problem is still remain. The workstation environment is listed as below :-

Windows XP 32 bits

SAP B1 2007 SP00 PL42

Does anybody know what might be causing this problem? I have reinstalled the DI API, B1 Client, .Net 3.5, Crystal Runtime and CR Addon v2.0.0.7 but no luck.

Please help.

Thank you.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 04, 2009 at 02:28 PM

    Hi Timothy ,

    I just recently did the crystal addon on one of the pc .So I think once you need to do clean reinstall and make sure when you uninstall ,restart your pc .Temporary files cause lot of issue. .

    Another ,

    When you download from SAP download , you will receive is crystal basic 2008.

    You need to download from differennt place to get crystal runtime addon .

    version mismatch is common problem .

    Check this Blog

    /people/richard.duffy/blog/2009/05/31/access-xcelsius-and-other-flash-content-by-updating-to-the-lastest-cr-runtime-and-net-viewer-with-sap-business-one

    Thank you

    Bishal

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 04, 2009 at 07:20 PM

    Hi.

    Please check this message: .

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 08, 2009 at 12:59 PM

    Hi Experts,

    Thank you for your solutions but it is still the same as before. I have downloaded the CR runtime version 12.1 and no luck.

    Ok, I have manually export the registrar CLSID {3EBB7859-E4E3-4D77-B673-C6E5AD529CC1} from the workstation that is working fine and import into the problematic workstation. At least, I am able to startup the CR addon without any problem. It asked to reset the sa password.

    After that, I try to run Account setup from Administration | Crystal Reports Administration | Account setup and it give me another type of error message.

    System Message

    -


    Unable to cast COM object of type 'CR_Crypto_cCryptoClass' to interface tyep 'CR_Crypot_cCrypto'. This operation failed because the QueryInterface call on the COM component for the interface with ID {B496590D-3881-44DA-BA31-5F98C197F846} failed due to the following erros No such interface supported (Exception form HRESULT:0x.88004002 (E_NOINTERFACE)).

    Do you have any idea?

    Thank you very much for your helps.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.