Skip to Content
author's profile photo Former Member
Former Member

Update SAP Content Repositry in SLD

Hi

We are planning to update SAP content repositry in XI Dev and XI Prd server.

XI DEV has the following information in Administration--> Details:

Required SAP CIM Model Version: 1.4.29

CR Content Version (sld/active): SAP_CR 2.3

Other Import Content Versions (sld/active): No other imports detected

Namespace Objects Classes Instances AssocClasses AssocInst QualDecl Model Version

sld/active 114277 252 42384 395 71216 30 1.4.31

XI PRD has the following information in Administration--> Details:

Required SAP CIM Model Version: 1.4.29

CR Content Version (sld/active): No versioned CR imports detected

Other Import Content Versions (sld/active): ALL 1.0

Namespace Objects Classes Instances AssocClasses AssocInst QualDecl Model Version

sld/active 113466 252 42039 395 70750 30 1.4.31

Questions:

1. Which is the current Model version? 1.4.31 or 1.4.29 in both servers. (I think it is 1.4.31 but would like to confirm it).

2. In XI Dev server, CR Content version is SAP_CR 2.3 but in XI PRD, no versioned CR imports detected. What could be the cause of this difference?

3. In XI DEV, there is no Other Import Content Versions (sld/active) detected but in XI PRD, it shows the value of ALL 1.0.

Any reason of difference?

can these differences in both instance create any problem during the update of CR?

oss note 669669 describe to update the SLD CR. If someone has some suggestions, pls share it with me.

Thanks

Amar

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Sep 04, 2009 at 04:46 AM

    1.Your Model Version is 1.4.31.

    2.3. This is absolutely fine. The SAP CR content was never directly imported to PRD. So, it says no version CR imports detected.

    The SAP CR content was imported into Dev. No other content was imported. Hence it says no Other Import Conetent.

    The CR content into PRD was imported from your dev/qa SLD.

    When you export the content from SLD, based on the options you chose, the data files will be generated.In your case, when the CR content was exported, ALL option was chosen, and hence you see ALL 1.0. This also indicates there was only one import.

    Next time when you export from Dev, the version would change.

    These things should not cause any issues. Please spend enough time in getting the details before you go for it.

    If you have noticed in the s-note, you have one import for model and several delta imports for CR content.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      The best way depends on what SLD architecture you have in your landscape. If you export from dev with the option all(It includes all the other landscape data as well), and import into prod, you are running the risk of bringing in some bad landscape data into prod.

      To be on safer side you can import into both dev and prod. you need to take a call after analyzing the situation.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.