Skip to Content
author's profile photo Former Member
Former Member

Publishing Web Service using Sender Soap Adapter P.71

Hi all,

Edited by: Fabio Ferri on Sep 3, 2009 2:58 PM

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 03, 2009 at 05:38 PM

    Hi Fabio,

    It seems your url in the wsdl is wrong. Try to create the wsdl uising this url:

    http://<host>:<j2ee-port>/XISOAPAdapter/MessageServlet?channel=:<service>:<channel>

    service is your sender business service and cahnnel is your sender communication channel name. Also try to put the full server complete name instead of w2kgjm24.

    You can refer this document:

    https://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/d23cbe11-0d01-0010-5287-873a22024f79&overridelayout=true

    I see your url has receiverservice, we dont need to this. Just try to create the same like I mentioned above.

    Regards,

    ---Satish

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Fabio,

      I see what you mean. I see in SOAP adapter faqs note: 856597. Here they specified if you dont use party then you need to have url:

      http://host:port/XISOAPAdapter/MessageServlet?senderParty=&senderService=FS&interface=IF&receiverParty=&receiverService=TS&interfaceNamespace=IFNamespace

      But the url you specified is not in this format. Eventhough if you dont use party dont delete just leave like that only. Thats what Sap note says:

      In a case when the sender channel or the receiver does not belong to a particualar Party leave the field empty in the URL, do not eliminate the parameter from the http URL, also do not use NULL instead in case of such channels. For instance, for a channel which does not belong to a particualr Sender Party and Receiver Party.

      So based upon this your url should be:

      http://w2kgjm24:50500/XISOAPAdapter/MessageServlet?senderParty=&senderService=BS_TESTE∫erface=SI_SOAP_SYNC_OUT&receiverParty=&receiverService=CC_EHP4_ECC_OUT_2∫erfaceNamespace=http://isec-iguatemi.com.br/sap/teste

      I am not sure whether I have used exactly the parameters you are having or not. But please see that notes and it is clearly mentioned there.

      Regards,

      ---Satish

  • Posted on Sep 03, 2009 at 05:42 PM

    Hey,

    Adding to Satish

    WSDL url - w2kgjm24 alone will not do.. give full host address

    What tool you are using to post the message ?

    Cheers

    Agasthuri

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 04, 2009 at 07:53 AM

    Dear Fabio,

    It is a very nice feature in PI 7.1.

    Just right click on your sender agreement and select the option to view WSDL. Everything is automatic.

    It will give you a URL to the WSDL directly. You can just share this URL with you consuming application.

    Everytime you change your signature, you dont need to send this again. Just ask the consuming application to update their reference.

    Regards,

    Vikas

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 05, 2009 at 10:29 AM

    Use the below URL format...it is working for me for SAP PI7.0 and 7.1 :

    http://<IPAddress OR ServerName>:<PORT_No>/XISOAPAdapter/MessageServlet?channel=:<SenderBusinessService>:<SenderSOAPCC>&version=3.0&Sender.Service=<SenderBusinessService>&Interface=<SenderInterfaceNamespace>%5E<SenderMI>

    No need to mentione any parameter for receiver service/ party....remove all the parameters which are not used....dont even leave a blank reference to the parameters.

    Regards,

    Abhishek.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.