Skip to Content
author's profile photo Former Member
Former Member

Print with Host spool access method C does not work anymore with V6R1

Hello,

after upgrading to V6R1 we have the problem that printing on devices with access method does not work anymore.

The log of the output requests contains these messages:

The operating system is reporting problems

Command used: OVRPRTF FILE(PRTF) USRDTA('0000463047') OUTPTY(5) OVRSCOPE(JOB) SPLFOWN(CURGRPPRF) CHRID(JOBCCSID) DEVTYPE(*USERASCII)

Error 0 (PrtMgrEndDoc)

Errors occurred processing this print request

Error during print request output. l_rc = 8

There may be no printout

In the joblog of the spool wp on os side, we see the message:

Parameters do not match those in program QDMVOVRP in QSYS.

Error found on OVRPRTF command.

Errors occurred in command.

We are using:

SAP Kernel 7.00 with Patch Level 211

CumPtf Level of V6R1 is 9111

I have found absolutely nothing in SMP and on IBM support site. Of course, in parallel i have created an oss message with SAP.

Anyone who came across the same problem when updating to V6R1 ?

Best regards,

Jürgen Scheckelhoff

Edited by: Juergen Scheckelhoff on Aug 31, 2009 10:19 AM

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Aug 31, 2009 at 11:57 AM

    Since it does work on our internal systems and should work in general, I suspect that you might have a back-level secondary language library (QSYS2924?) in the library list of the spool work process. If you don't have a secondary language installed, check if there is any library prior to QSYS in the work process library list, and if so, if it contains the command OVRPRTF.

    If the whole secondary language library is backlevel, you must either upgrade or delete it. If only the command OVRPRTF is backlevel, then you should check why you need it (maybe changed command defaults?), and then delete it, copy the version from QSYS and modify it as needed.

    Kind regards,

    Chrsitian Bartels.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Christian...

      I have the same problem but after a migration to IBM i V7R1 and kernel 7.20 Patch Level 401 ILE 428.

      The difference is that neither in the OS or SAP were any error messages.

      I have checked your answer to Jürgen and we already have language 2924 installed.

      ¿Any suggestions?

      Thanks in advance.

      Jose Dominguez

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.