Skip to Content
0

Inconsistent OLE Object Picture displaying

Nov 18, 2016 at 03:01 AM

43

avatar image
Former Member

Dear All,

Please see my question below. None of the troubleshooting works. Appreciate someone could assist on this as i have been trying to fix it for months. Thank you

1. Design
- I am using OLE object to display the photo.
- The pictures are store on the file server as a physical file
- Program pass the file path to crystal report during runtime

2. Problem
- The picture displaying inconsistent.First time display usually all picture not shown or few shown
- The subsequent attempt may display all the pictures. The number of attempt to display all the photo is not fixed. Sometimes we can see all the pictures even in first attempt.
- When i use attempt, it means my VB winform program is not exit. Cause i use button click action to call the crystal report. Attempt means i click the button once again without closing the program

3. Troubleshooting
- I have updated the runtime library to the latest version
- I have even copy all the picture to local drive to find out whether is server performance issue
- The RPT was created in crystal report version 2011. I have tried to install the version 2016 and save the file again to check whether is version issue.
- I have created a new RPT and remove unnecessary field and just to include the same picture display portion only and still the same problem.
- I have tried not to use crystal report viewing and directly export the RPT document to a disk file. Same problem as well

4. Screenshot

Attemp 1 (None of the picture display in 1st click)

Attempt 2 (1 picture displayed when i close the screen and perform second click)

Attempt 3 (All pictures are display correctly)

attempt-1.png (103.1 kB)
attempt-2.png (130.1 kB)
attempt-3.png (213.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers