Skip to Content
author's profile photo Former Member
Former Member

Report Displays in Viewer but Web Print produces blank pages

I am using VS 2008 w CR 2008 SP2 in a web application deployed on Win2008.

I have set the report to display all pages so that the users can hit the print button on their browser (IE7). When the report is shown in the report viewer it looks perfect. When the print button on the browser is used blank pages with the url on top/bottom of each page print, but there is no report.

If I use the print preview and turn on the background layers, I can see that the report background is on two and half pages, which would be corect; but there is no report text or data.

Any ideas?

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 09, 2009 at 05:34 PM

    Hello,

    If you page through the report in the viewer is all the data visible?

    Have you handled the postback event so that the report is in session before you print?

    Look at the samples in the Crystal Reports Visual Studio .NET [Samples|http://www.sdn.sap.com/irj/boc/sdklibrary?rid=/library/uuid/d0bf8496-2a81-2b10-95ac-b1f48d5b63f5]. Go to the "ReportDocument_Object_Model_Tutorials" and look at the "RDObjMod_Session" sample.

    There are also different methods for printing from the web. Printing from the Print control on the viewer downloads an ActiveX print control to the local system. The user needs to have Administrator rights for it to install and register. For information on web printing options look at the article[ "Printing Web based reports with Crystal Reports for Visual Studio .NET"|http://www.sdn.sap.com/irj/boc/index?rid=/library/uuid/600c24a3-ab1d-2b10-1bb4-c50562e353cb].

    Elaine

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 07, 2009 at 05:52 PM

    Sorry moved between projects...back to this one.

    I have set up the viewer to always show all pages. If there is a single page to print, everything works fine. When there are mutliple pages the viewer look great(all information correctly displayed), the print preview will display no information, except what I described before.

    I do not use session variables in my application, nore do I have a postback condition on the form.

    I followed the steps from the SAP white paper on printing using the browser, I did not see anything about using session varialbes there.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.